View Issue Details

IDProjectCategoryView StatusLast Update
0002632Kali Linux[All Projects] Kali Package Bugpublic2020-12-01 10:48
Reporterdimitriosz Assigned To 
Status resolvedResolutionfixed 
Product Version2.0 
Target VersionFixed in Version2.0 
Summary0002632: SET
DescriptionThe Social Engineering Toolkit is no longer working within Kali v2.x. Tried the Clone of a website part and nothing. Not sure why? It seems not to be writing to the .txt files, the harvester files.
Please advise?



2015-09-09 17:20

reporter   ~0003974

Try changing the access permissions of the /var/www/html folder so that other users can read and write there. Here is a screenshot:


2015-09-10 20:39

reporter   ~0003978

Thank you.
That worked, but when SET does that action it should also copy files to the /var/www/html folder and not the /var/www folder.
So I had to move the files there too and then it would work.
Is there anywhere in SET I can fix that? The website clone part?


2015-09-10 23:15

reporter   ~0003981

Edit /etc/setoolkit/set.config and under "### Path to the Apache web root.", set APACHE_DIRECTORY=/var/www/ to APACHE_DIRECTORY=/var/www/html/ . This bug is also fixed in a newer version of SET .


2015-09-11 14:19

manager   ~0003986

I just pushed the new version 6.5.6-0kali1 of set in sana-proposed-updates.
You will have to add sana-proposed-updates in your /etc/apt/sources.list
Please test and let me know if it fixes this issue.


2015-09-12 09:10

reporter   ~0003989

The problem with the cloned website location is fixed, but I still have to manually change the /var/www/html folder permissions so that other users than root can write and delete files there. Also when the a website is cloned, the automatically created harvester.txt remains in /var/www/, but this is not a big problem, because I can delete it manually.

Issue History

Date Modified Username Field Change
2015-09-08 23:56 dimitriosz New Issue
2015-09-09 17:20 yennefer1173 Note Added: 0003974
2015-09-10 20:39 dimitriosz Note Added: 0003978
2015-09-10 23:15 yennefer1173 Note Added: 0003981
2015-09-11 14:19 sbrun Note Added: 0003986
2015-09-12 09:10 yennefer1173 Note Added: 0003989
2015-09-14 07:16 sbrun Status new => resolved
2015-09-14 07:16 sbrun Resolution open => fixed
2015-09-14 07:16 sbrun Fixed in Version => 2.0
2015-11-06 23:44 bhjr Issue cloned: 0002780
2020-12-01 10:48 g0tmi1k Priority high => normal