View Issue Details

IDProjectCategoryView StatusLast Update
0002998Kali Linux[All Projects] General Bugpublic2017-08-30 08:33
Reporterdomdorn Assigned Torhertzog  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.0 
Target VersionFixed in Version 
Summary0002998: Live-CD / USB Hangs on MacBook Pro Retina 2015 - GRUB graphical issue - fix included
DescriptionI have a MacBook Pro 2015 Retina.

I downloaded Kali 2.0 and created a bootable USB.

I've read through the stuff at
https://forums.kali.org/showthread.php?26670-Kali-2-0-Installation-Tips-for-Macbook-Pro-2015-Retina

The Bootloader hangs in 90% of the time. I found out, that this is an issue with the Grub graphical configuration.

After I changed the /EFI/BOOT/stdmenu.cfg and disabled all the graphical adjustments, I could reproducible get the boot loader to work.

I attached the "fixed" file to this bug report.

Activities

domdorn

2016-01-17 23:07

reporter  

stdmenu.cfg (604 bytes)

rhertzog

2016-01-18 13:28

administrator   ~0004514

Just to clarify, you're speaking of booting on the ISO after having copied it on an USB key... and you refer to the Syslinux bootloader where you decide whether you boot in live mode or you install a new Kali system. Is that correct?

I seek clarifications because you mention grub but at the same time you modify stdmenu.cfg which is a syslinux file.

rhertzog

2016-01-18 13:31

administrator   ~0004515

Also can you let me know if you have the same problem with this ISO image:
http://archive.kali.org/kali-daily-images/kali-linux-light-rolling-amd64.iso

Thank you.

domdorn

2016-01-18 15:16

reporter   ~0004519

@rhertzog: yes, i've downloaded the iso and created a bootable usb stick out of it. yes its syslinux .. my mind was stuck with it being grub.. sorry for the confusion.

So to clarify: "the Syslinux bootloader hangs / does not respond to input when booting a macbook pro mid 2015 retina with the supplied graphical configuration as in the 2.0 release. after removing the nice graphic tweaks in EFI/BOOT/stdmenu.cfg, the syslinux bootloader is responsive to user input and allows to choose a boot option and execute this option."

I will try with the new iso tonight.

domdorn

2016-01-18 19:09

reporter   ~0004520

Last edited: 2016-01-18 19:31

View 3 revisions

i cannot open this iso on my mac nor boot from it. in comparison to the other iso (the one including the live distribution), this one does not have a second partition with the EFI files on it.

btw. checksums would be great.. I have this sha1:
d116bc36437dedbd4b2c0b75d87d8acfc7f3e64d kali-linux-light-rolling-amd64.iso

rhertzog

2016-01-19 14:51

administrator   ~0004521

Gah, that was an unexpected regression. Thanks for letting us know. Can you check again tomorrow with the new ISO that will be available then? TIA. (Today's image has the same problem)

domdorn

2016-01-19 16:48

reporter   ~0004522

Ok I check the latest file with server timestamp >~ 20-Jan-2016 04:00

domdorn

2016-01-19 16:49

reporter   ~0004523

btw. it would really be nice if kali could make the cd like ubuntu, where everything is in one partition and I could - at least on the usb stick - change everything. That way I could also add additional firmware easily to the firmware folder

domdorn

2016-01-20 15:48

reporter   ~0004528

I've tried
kali-linux-light-rolling-amd64.iso and kali-linux-next-amd64.iso
both don't contain a "mountable file system."

rhertzog

2016-02-05 14:08

administrator   ~0004664

Did you try to the 2016.1 ISO that we released recently?

domdorn

2016-02-05 17:38

reporter   ~0004665

I just tried with the 2016.1 full iso ( kali-linux-2016.1-amd64 )

- I was able to create a bootable usb-stick
- when trying to boot the stick, the screen stayed black
- i then changed EFI/BOOT/stdmenu.cfg
 + I commented out the follwing lines
#menu background splash.png <-- this is probably the most important one
#menu vshift 10
#menu hshift 4
#menu width 70
#menu margin 5
#menu rows 10
#menu helpmsgrow

After saving the file and rebooting to the stick, I could see the boot menu (just with grey background and white text, but at least it was usable) and selected the live version.

I was able to boot kali live, I was able to join a wifi and use the system.

Unfortunately I was not able to put my wifi adapter into monitoring mode ( I wanted to play with airmon-ng ) ... not sure if I would need a special firmware for my adapter to be usable for this.

So to summarize: After changing the stdmenu.cfg file, I can boot into the live version of kali / use the boot menu as expected.

I think the problem with the splash image has something to do with the retina display of the mac, but thats just a guess.

thenewday13

2016-03-16 12:01

reporter   ~0004857

Hello, i have a problem when i try to boot, i install refind , but dose't work, when i try to boot say "No system" bootable or something like that , black screen try to boot but nothing, press any key to continue, but nothing happen,i have Macbook Pro 2009, please help me thank you

thenewday13

2016-03-18 02:37

reporter   ~0004982

Last edited: 2016-03-18 02:41

View 2 revisions

Admin-rhertzog
 - where i can send you some picture please.
i need help, i make usb bootable same way like domdorn
 -i pass the black screen by chose graphical install ,
-i already install refind ,
- i make a partition after complete install , i try to boot the sytem, nothing happen it say " operating system not found "
-i can see partition in disk utility byt i can't mount
I have macbook pro 2009 early
thank you!
P.S i try both system normal and light same problem, i can't acces the system even live, ....

rhertzog

2017-08-30 08:33

administrator   ~0007196

At this point, I think it's unlikely we will be able to deal further with this request. So I'm closing the ticket. Hardware support issues are difficult to deal.

Issue History

Date Modified Username Field Change
2016-01-17 23:07 domdorn New Issue
2016-01-17 23:07 domdorn File Added: stdmenu.cfg
2016-01-18 13:28 rhertzog Note Added: 0004514
2016-01-18 13:31 rhertzog Note Added: 0004515
2016-01-18 13:43 rhertzog Assigned To => rhertzog
2016-01-18 13:43 rhertzog Status new => feedback
2016-01-18 15:16 domdorn Note Added: 0004519
2016-01-18 15:16 domdorn Status feedback => assigned
2016-01-18 19:09 domdorn Note Added: 0004520
2016-01-18 19:31 domdorn Note Edited: 0004520 View Revisions
2016-01-18 19:31 domdorn Note Edited: 0004520 View Revisions
2016-01-19 14:51 rhertzog Note Added: 0004521
2016-01-19 16:48 domdorn Note Added: 0004522
2016-01-19 16:49 domdorn Note Added: 0004523
2016-01-20 15:48 domdorn Note Added: 0004528
2016-02-05 14:08 rhertzog Note Added: 0004664
2016-02-05 17:38 domdorn Note Added: 0004665
2016-03-16 12:01 thenewday13 Note Added: 0004857
2016-03-18 02:30 thenewday13 Note View State: 0004857: private
2016-03-18 02:30 thenewday13 Note View State: 0004857: public
2016-03-18 02:37 thenewday13 Note Added: 0004982
2016-03-18 02:41 thenewday13 Note Edited: 0004982 View Revisions
2017-08-30 08:33 rhertzog Status assigned => closed
2017-08-30 08:33 rhertzog Resolution open => won't fix
2017-08-30 08:33 rhertzog Note Added: 0007196