View Issue Details

IDProjectCategoryView StatusLast Update
0003014Kali Linux[All Projects] General Bugpublic2016-01-29 23:26
Reporterslick97454Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0 
Target VersionFixed in Version2016.2 
Summary0003014: Regression in monitor mode of some Ralink cards with Linux 4.3 of Kali 2016.1
DescriptionHave just installed the latest Kali 2.0 2016 rolling release. I have a ralink adapter with a rt2870 chip which uses the rt2800usb firmware. When trying to use anything with monitor mode with this chipset i cannot see associated clients. There is a issue with rt2800usb firmware. I have confirmed it. My toughbook has just Kali 2.0 installed and updated but not to the rolling release. It works and can see Associated clients. However on the newest kernel that comes with the rolling release it does not work. I have tried multiple things to try and get it to work and it wont. It can see clients for instance in airodump-ng but it cannot them being associated with the AP. Even with a device sitting right next to my AP it cant see them, however if i go to my toughbook that has the older kernel everything works just fine,
Steps To ReproduceI can reproduce it with anything that has to do with monitor mode with the ralink rt2870 chipset on Newest kernel on Kali 2.0 2016 rolling release
Additional InformationOutput of lsusb:
Bus 004 Device 003: ID 18e3:9106 Fitipower Integrated Technology Inc
Bus 004 Device 002: ID 046d:09a1 Logitech, Inc. QuickCam Communicate MP/S5500
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 05ba:000a DigitalPersona, Inc. Fingerprint Reader
Bus 005 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0
Bus 002 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Activities

two_factor

2016-01-26 14:49

reporter   ~0004614

Hello,

Very similar problem here.

USB wireless adaptor : Alfa AWUS052NH (Ralink RT3572 chipset, rt2800usb/rt2x00usb modules)

Steps to reproduce :
1. airmon-ng start wlan0
2. airbase-ng -e "My_AP" -c 11 wlan0mon

Tap device at0 is created, the access point is visible from neighbouring clients, but cannot be associated with them. airbase-ng doesn't display any output when a client tries to connect.

I tried on 3 different machines, and also tried to disable ipv6 completely, without success.

On Sana (Kali 2.0), the AP can be associated without problem.

Seems like a kernel-related problem, I don't know if you Kali folks can do anything about this issue... Thanks anyway.

two_factor

2016-01-26 18:52

reporter   ~0004617

Found the same problem with the PCI version of these Ralink modules :
- device : "Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe"
- modules : rt2800pci, rt2x00pci, etc.
Access point works on Sana/2.0, but not on current rolling-release.

slick97454

2016-01-27 06:29

reporter   ~0004620

I have decided to downgrade to "4.0.0-kali1-amd64 0000001 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux" This is the kernel version I am using as noted above by two_factor and everything works great now. Before downgrading I used many different usb,pci, and pcie ralink based wifi adpaters and it seems any of them that use the rt2800usb, rt2800pci or anything ralink will not see associated clients at all. It would seem this is definately a kernel issue with the supplied ralink drivers and firmware. Not sure if this help but this is current output from lshw.

"description: Wireless interface
       product: 802.11 n WLAN
       vendor: Ralink
       physical id: 4
       bus info: usb@1:4
       logical name: wlan0
       version: 1.01
       serial: 1.0
       capabilities: usb-2.00 ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.0.0-kali1-amd64 firmware=0.29 link=no maxpower=450mA multicast=yes speed=480Mbit/s wireless=IEEE 802.11bgn"

rhertzog

2016-01-27 10:40

administrator   ~0004623

I tried to find other reports of similar problems but was unable to find anything relevant.

It would be nice if we could identify more precisely when it stopped working. Currently we know it's at some point between Linux 4.0 and 4.3.3. Can you try with Linux 4.2 ? And possibly also with Linux 4.4 ?

You can grab various (older) versions from snapshot.debian.org:
http://snapshot.debian.org/package/linux/

The .deb for Linux 4.2.6:
http://snapshot.debian.org/archive/debian/20151206T095812Z/pool/main/l/linux/linux-image-4.2.0-1-amd64_4.2.6-3_amd64.deb

The .deb for Linux 4.4:
http://snapshot.debian.org/archive/debian/20160121T041313Z/pool/main/l/linux/linux-image-4.4.0-trunk-amd64_4.4-1%7Eexp1_amd64.deb

Otherwise if you know how to compile a kernel from sources, a git bisect to identify when it stopped working would be really useful.

rhertzog

2016-01-27 11:14

administrator   ~0004624

Just want to double check, do you have the "firmware-misc-nonfree" package installed at version 20160110-1?

(You can check with "dpkg -s firmware-misc-nonfree")

Please also attach the output of "dmesg" with the kernel that does not work after having tried to use the wifi card in monitor mode.

rhertzog

2016-01-27 13:09

administrator   ~0004626

Upstream is aware of the problem and there's a patch available already:
http://marc.info/?l=linux-wireless&m=145311668331789&w=2

rhertzog

2016-01-27 13:24

administrator   ~0004627

Should be fixed with linux 4.3.3-7kali2 that I just uploaded to kali-dev.

muts

2016-01-29 23:26

administrator   ~0004637

until its pushed to the main repo, you can try to add the following line to your sources.list, and update the kernel. Don't forget to reboot once done.

deb http://http.kali.org/kali kali-dev-only main non-free contrib

Note: please make sure to remove this repository once you're done testing. Keeping it in your sources.list is a recipe to break things down the road.

Issue History

Date Modified Username Field Change
2016-01-25 05:44 slick97454 New Issue
2016-01-26 14:49 two_factor Note Added: 0004614
2016-01-26 18:52 two_factor Note Added: 0004617
2016-01-27 06:29 slick97454 Note Added: 0004620
2016-01-27 10:40 rhertzog Note Added: 0004623
2016-01-27 10:40 rhertzog Assigned To => rhertzog
2016-01-27 10:40 rhertzog Status new => assigned
2016-01-27 11:14 rhertzog Note Added: 0004624
2016-01-27 13:09 rhertzog Note Added: 0004626
2016-01-27 13:24 rhertzog Note Added: 0004627
2016-01-27 13:24 rhertzog Status assigned => resolved
2016-01-27 13:24 rhertzog Fixed in Version => 2016.2
2016-01-27 13:24 rhertzog Resolution open => fixed
2016-01-27 13:25 rhertzog Summary Kali 2.0 rolling release => Regression in monitor mode of some Ralink cards with Linux 4.3 of Kali 2016.1
2016-01-29 23:26 muts Note Added: 0004637
2016-01-30 18:02 ayamhitam Issue cloned: 0003028