View Issue Details

IDProjectCategoryView StatusLast Update
0003074Kali Linux[All Projects] General Bugpublic2016-02-18 14:06
Reportersteev Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003074: debootstrap: Two-staged bootstrapping with --second-stage broken
Descriptiondebootstrap 1.0.78 is currently broken with regards to using --foreign.

This is already in debian's bug tracker, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813232
Additional InformationUntil the issue is fixed, a possible workaround is to use qemu-debootstrap.

 This affects building arm images when using kali 2016.1 and newer releases.

Activities

rhertzog

2016-02-18 13:59

administrator   ~0004724

Hi, do you need a quick fix on the Kali side or can we wait until it's fixed on the Debian side?

rhertzog

2016-02-18 14:06

administrator   ~0004725

In fact the bug is already fixed on the Debian side so I just imported the fixed package. It's fixed with debootstrap_1.0.78+nmu1+kali1.dsc uploaded to kali-dev.

Issue History

Date Modified Username Field Change
2016-02-16 18:51 steev New Issue
2016-02-16 18:51 steev Status new => assigned
2016-02-16 18:51 steev Assigned To => rhertzog
2016-02-18 13:59 rhertzog Note Added: 0004724
2016-02-18 14:06 rhertzog Note Added: 0004725
2016-02-18 14:06 rhertzog Status assigned => resolved
2016-02-18 14:06 rhertzog Fixed in Version => 2016.2
2016-02-18 14:06 rhertzog Resolution open => fixed