View Issue Details

IDProjectCategoryView StatusLast Update
0003080Kali Linux[All Projects] Kali Package Bugpublic2016-02-19 15:48
ReporterjonathanyhsuAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.1 
Summary0003080: airodump-ng crashes with Illegal instruction message
DescriptionI'm running the rolling update Kali Linux on a 2012 Dell Latitude E6400 laptop. After updating the aircrack-ng package to 1:1.2-0~rc4-0kali1 the airodump-ng binary always crashes/exits with the message "Illegal instruction" and nothing else. The default X11 terminal also loses the cursor (i.e. it goes transparent) until the "reset" command is given.

This happens both with the on-board Intel Corporation WiFi Link 5100 wifi interface, or a TP-LINK TL-WN722N USB adapter with an Atheros chipset.

Some internet searching yielded an aircrack-ng bug that appears similar, but is very old and may not be the same issue: http://trac.aircrack-ng.org/ticket/154

Dumps of /proc/cpuinfo and uname -a are included in the "Additional Information" section.
Steps To Reproducesudo apt-get update
sudo apt-get upgrade -y; sudo apt-get dist-upgrade -y
sudo airmon-ng check kill
sudo airmon-ng start wlan0
sudo airodump-ng wlan0mon
Additional Informationcat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz
stepping : 10
microcode : 0xa0c
cpu MHz : 2800.000
cache size : 6144 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida dtherm tpr_shadow vnmi flexpriority
bugs :
bogomips : 5586.44
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz
stepping : 10
microcode : 0xa0c
cpu MHz : 800.000
cache size : 6144 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida dtherm tpr_shadow vnmi flexpriority
bugs :
bogomips : 5586.44
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

uname -a
Linux kali 4.3.0-kali1-amd64 0000001 SMP Debian 4.3.5-1kali1 (2016-02-11) x86_64 GNU/Linux

apt-cache policy aircrack-ng
aircrack-ng:
  Installed: 1:1.2-0~rc4-0kali1
  Candidate: 1:1.2-0~rc4-0kali1
  Version table:
 *** 1:1.2-0~rc4-0kali1 500
        500 http://http.kali.org/kali kali-rolling/main amd64 Packages
        100 /var/lib/dpkg/status

Activities

jonathanyhsu

2016-02-18 22:55

reporter  

cpuinfo (1,613 bytes)
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     T9600  @ 2.80GHz
stepping	: 10
microcode	: 0xa0c
cpu MHz		: 2800.000
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida dtherm tpr_shadow vnmi flexpriority
bugs		:
bogomips	: 5586.44
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     T9600  @ 2.80GHz
stepping	: 10
microcode	: 0xa0c
cpu MHz		: 800.000
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida dtherm tpr_shadow vnmi flexpriority
bugs		:
bogomips	: 5586.44
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

cpuinfo (1,613 bytes)

rhertzog

2016-02-19 09:36

administrator   ~0004731

It looks like aircrack-ng got some autoconfiguration logic enabling usage of some CPU features which are not used by the default compiler. So the package uses AVX instructions and you don't have those.

We will fix the package to not rely on newer CPU features.

sbrun

2016-02-19 13:10

manager   ~0004734

The new version 1:1.2-0~rc4-0kali3 should fix this. It will be available in the next hours.

jonathanyhsu

2016-02-19 15:29

reporter   ~0004740

Thanks; I updated aircrack-ng to 1:1.2-0~rc4-0kali3 and the issue is resolved and no longer present.

Issue History

Date Modified Username Field Change
2016-02-18 22:55 jonathanyhsu New Issue
2016-02-18 22:55 jonathanyhsu File Added: cpuinfo
2016-02-19 09:36 rhertzog Note Added: 0004731
2016-02-19 09:37 rhertzog Assigned To => sbrun
2016-02-19 09:37 rhertzog Status new => assigned
2016-02-19 13:10 sbrun Note Added: 0004734
2016-02-19 15:29 jonathanyhsu Note Added: 0004740
2016-02-19 15:48 sbrun Status assigned => resolved
2016-02-19 15:48 sbrun Resolution open => fixed
2016-02-19 15:48 sbrun Fixed in Version => 2016.1