View Issue Details

IDProjectCategoryView StatusLast Update
0003112Kali Linux[All Projects] Kali Package Bugpublic2016-03-16 05:42
Reporterbusterb Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003112: bundler 1.10.6 packaged with kali-rolling has a bug running the latest metasploit-framework
DescriptionIf a user checks out metasploit-framework from git, and uses ruby 2.2.4 and bundler 1.10.6 packaged currently with kali-rolling, bundler fails with a backtrace:

/usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `block in initialize': undefined method `add_root_vertex' for Molinillo::DependencyGraph:[]:Molinillo::DependencyGraph (NoMethodError)
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `initialize'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `new'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:200:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:140:in `specs'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:185:in `specs_for'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:174:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler.rb:127:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:8:in `<top (required)>'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from /root/metasploit-framework/config/boot.rb:26:in `<top (required)>'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from ./msfconsole:45:in `<main>'
Steps To Reproducegit clone http://metasploit-framework
bundle install

root@kali:~/metasploit-framework# ./msfconsole
/usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `block in initialize': undefined method `add_root_vertex' for Molinillo::DependencyGraph:[]:Molinillo::DependencyGraph (NoMethodError)
Additional InformationDespite our warnings to users that they should be using isolated gemsets, folks seem to want to have checking out the latest framework on Kali 'just work', and it looks like upgrading bundler should do it.

I suppose we could also suggest to users of kali to set GEM_PATH specially, or use the special ruby wrapper supplied with kali-rolling:

~/metasploit-framework# /usr/share/metasploit-framework/ruby ./msfconsole

We do recommend setting up rvm and having an isolated gemset when doing development, but it would be nice if kali-rolling is tracking the latest bundler to get this bug fixed.

Activities

rhertzog

2016-03-02 15:16

administrator   ~0004804

We just switched kali-rolling to the bundler version packaged in Debian testing: 1.11.2. It should be available on the Kali mirrors in a few hours.

Please reopen if this is not enough to fix your issue.

Issue History

Date Modified Username Field Change
2016-03-02 13:56 busterb New Issue
2016-03-02 15:16 rhertzog Note Added: 0004804
2016-03-02 15:16 rhertzog Status new => closed
2016-03-02 15:16 rhertzog Assigned To => rhertzog
2016-03-02 15:16 rhertzog Resolution open => fixed
2016-03-02 15:16 rhertzog Fixed in Version => 2016.2