View Issue Details

IDProjectCategoryView StatusLast Update
0003192Kali Linux[All Projects] Kali Package Bugpublic2016-04-06 09:19
ReporterUNATCO Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003192: sqlsus error
DescriptionClean LUKS Encrypted Hard Drive Installation of Current Kali Rolling to Bootable USB Drive.

Only updates since install are:

apt-get update && apt-get upgrade && apt-get dist-upgrade

gem update

airodump-ng-oui-update

wpscan --update

When opening sqlsus from applications menu the following error is returned and sqlsus not run:

Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at /usr/bin/sqlsus line 80.
Steps To ReproduceRun sqlsus in clean install.

Activities

rhertzog

2016-03-31 14:38

administrator   ~0005056

This is a backwards incompatible change in recent perl versions.

We should look if there's a new upstream version with a fix. Or we could patch it ourselves.

UNATCO

2016-03-31 22:36

reporter   ~0005065

Seems that sqlsus 0.7.2 was the final release on 1/13/2012.

http://sqlsus.sourceforge.net/

And here is the author's contact information.

Jérémy Ruffet (sativouf) : sativouf <at> gmail -dot- com

After searching, am not able to locate a newer version.

Just emailed the author with a link to this post. Will keep everyone updated about a response.

P.S.- Not much of a coder yet or would work on a patch myself. :/

sbrun

2016-04-06 09:19

manager   ~0005090

We patch it ourselves.
The new version is 0.7.2-1kali1.

Issue History

Date Modified Username Field Change
2016-03-27 04:40 UNATCO New Issue
2016-03-31 14:37 rhertzog Assigned To => sbrun
2016-03-31 14:37 rhertzog Status new => assigned
2016-03-31 14:38 rhertzog Note Added: 0005056
2016-03-31 22:36 UNATCO Note Added: 0005065
2016-04-06 09:19 sbrun Note Added: 0005090
2016-04-06 09:19 sbrun Status assigned => resolved
2016-04-06 09:19 sbrun Resolution open => fixed
2016-04-06 09:19 sbrun Fixed in Version => 2016.2