2017-12-17 10:05 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003332Kali Linux[All Projects] Tool Upgradepublic2017-09-18 21:04
Reporterfabidick 
Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003332: Synaptics touchpad not properly configured in GNOME 3.20
DescriptionAfter running
apt-get update
apt-get upgrade
apt-get dist-upgrade
My touchpad settings are removed.
Then try to reset my settings but does not show me my touchpad settings.

Sorry for my english!
Attached Files

-Relationships
+Relationships

-Notes

~0005341

dannyrock777 (reporter)

check this fix worked for me
http://www.shelltutorials.com/how-to-fix-the-touch-pad-which-is-not-working-after-upgrade-in-kali-linux/

~0005379

fabidick (reporter)

Thank you very much!

~0005381

rhertzog (administrator)

Do you have xserver-xorg-input-libinput installed?

Please paste the output of "dpkg -l |grep xserver-xorg-input".

~0005431

fabidick (reporter)

ii xserver-xorg-input-all 1:7.7+15 amd64 X.Org X server -- input driver metapackage
ii xserver-xorg-input-evdev 1:2.10.2-1 amd64 X.Org X server -- evdev input driver
ii xserver-xorg-input-libinput 0.19.0-1 amd64 X.Org X server -- libinput input driver
ii xserver-xorg-input-mouse 1:1.9.1-1+b1 amd64 X.Org X server -- mouse input driver
ii xserver-xorg-input-synaptics 1.8.3-2 amd64 Synaptics TouchPad driver for X.Org server
ii xserver-xorg-input-synaptics-dev 1.8.3-2 all Synaptics TouchPad driver for X.Org server (development headers)
ii xserver-xorg-input-vmmouse 1:13.1.0-1+b1 amd64 X.Org X server -- VMMouse input driver to use with VMWare
ii xserver-xorg-input-wacom 0.30.0-1+b1 amd64 X.Org X server -- Wacom input driver

~0005432

rhertzog (administrator)

Can you try to remove xserver-xorg-input-synaptics and reboot and let me know if it works better afterwards?

apt remove xserver-xorg-input-synaptics

~0005433

fabidick (reporter)

yes, Everthing back to the normality!
thanks man!

~0005493

rhertzog (administrator)

So the underlying problem is that GNOME 3.20 nowadays uses libinput to configure the touchpads, but on the Xorg side, the synaptics driver takes precedence over the libinput one so nothing gets configured as the hardware is managed by the synaptics driver.

The known workaround is to remove xserver-xorg-input-synaptics so that libinput handles the touchpad... but this is a bit clumsy as xserver-xorg-input-all depends on thy synaptics driver and we usually don't want any input method to be removed.

~0005516

rhertzog (administrator)

I started a discussion about this on debian-devel: https://lists.debian.org/debian-devel/2016/07/msg00266.html

I also uploaded new versions of xserver-xorg-input-all (7.7+16~kali1) and kali-desktop-gnome (2016.2.7) to Kali to fix the problem in Kali but I fear it will break KDE and other desktop environments that are not yet able to use libinput...

~0005517

rhertzog (administrator)

I also submitted this upstream: https://bugzilla.gnome.org/show_bug.cgi?id=768682

~0005518

Tcrew (reporter)

my problem is not fixed yet... i´ve done what you wrote, but nothing changed. Still not working for me.

~0005519

rhertzog (administrator)

Tcrew, just stating this won't help us to understand what's happening on your machine. Also your problem description is rather superficial...

Share the logs of your running Xorg, install libinput-tools and run the command line tool to figure out whether your touchpad is properly detected by libinput, etc.

Also explain what your problem is. Is it in GNOME control center not showing your touchpad ? Or does it show it but does not remember/apply the settings, etc.

~0005523

Tcrew (reporter)

http://pastebin.com/90C3vjPi
http://pastebin.com/Bx5PikD4
http://pastebin.com/rB4B07TQ
http://pastebin.com/hA3bDyS4

all messages like dmesg full, with external mouse and without external mouse
xorg logs

hope that helps to help me :D

~0005524

rhertzog (administrator)

Tcrew, sorry but no. None of the log messages show any mention about a possible touchpad... your problem is unrelated to the bug handled in this ticket and I advise you to try to get help on forums instead. If you decide to file a new bug, you should provide details about the touchpad integrated in your laptop.

~0005536

Tcrew (reporter)

can you reopen my report then please?

because its not the same problem as you said but my windows on same machine say

PCI\VEN_8086&DEV_9C45&SUBSYS_182610CF&REV_04\3&11583659&0&F8

https://i.imgsafe.org/518abee5e5.png

and this is a screenshot from the driver settings

~0005537

Tcrew (reporter)

and this is funny .. xfce has found my touchpad.. but not working
https://i.imgsafe.org/5276412387.png

~0005697

rhertzog (administrator)

This has been somewhat resolved on the Debian side by dropping synaptics Xorg driver from the default installation.
+Notes

-Issue History
Date Modified Username Field Change
2016-06-02 22:08 fabidick New Issue
2016-06-02 22:08 fabidick File Added: Captura de pantalla de 2016-06-02 16-33-36.png
2016-06-08 00:32 dannyrock777 Note Added: 0005341
2016-06-16 14:58 fabidick Note Added: 0005379
2016-06-16 19:07 rhertzog Note Added: 0005381
2016-06-16 19:07 rhertzog Assigned To => rhertzog
2016-06-16 19:07 rhertzog Status new => feedback
2016-06-28 12:18 fabidick Note Added: 0005431
2016-06-28 12:18 fabidick Status feedback => assigned
2016-06-28 13:25 rhertzog Note Added: 0005432
2016-06-28 13:25 rhertzog Status assigned => feedback
2016-06-28 14:41 fabidick Note Added: 0005433
2016-06-28 14:41 fabidick Status feedback => assigned
2016-07-11 08:47 rhertzog Note Added: 0005493
2016-07-11 08:47 rhertzog Summary Shows no touchpad settings => Synaptics touchpad not properly configured in GNOME 3.20
2016-07-11 14:47 rhertzog Note Added: 0005516
2016-07-11 14:54 rhertzog Note Added: 0005517
2016-07-11 15:22 Tcrew Note Added: 0005518
2016-07-11 15:56 rhertzog Note Added: 0005519
2016-07-11 20:26 Tcrew Note Added: 0005523
2016-07-11 21:17 rhertzog Note Added: 0005524
2016-07-12 16:20 Tcrew Note Added: 0005536
2016-07-12 17:23 Tcrew Note Added: 0005537
2016-07-22 10:39 Be4stElectrjc Note Added: 0005572
2016-07-22 10:40 Be4stElectrjc Note Edited: 0005572 View Revisions
2016-07-22 10:41 Be4stElectrjc Note Edited: 0005572 View Revisions
2016-07-22 10:42 Be4stElectrjc Note Edited: 0005572 View Revisions
2016-07-22 10:42 Be4stElectrjc Note Edited: 0005572 View Revisions
2016-07-22 11:06 Be4stElectrjc Note Deleted: 0005572
2016-08-29 16:09 rhertzog Note Added: 0005697
2016-08-29 16:09 rhertzog Status assigned => resolved
2016-08-29 16:09 rhertzog Fixed in Version => 2016.2
2016-08-29 16:09 rhertzog Resolution open => fixed
+Issue History