View Issue Details

IDProjectCategoryView StatusLast Update
0003339Kali Linux[All Projects] Kali Package Bugpublic2016-06-08 08:11
Reporterdannyrock777 Assigned Tosbrun  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003339: dist-upgrade messup with the pyqt4 so after dist-upgrade sparta , creepy are not working didnt checked any other program yet.
Descriptionwhile launching sparta
root@io:~# sparta
[-] Import failed. PyQt4 library not found.
Try installing it with: apt-get install python-qt4
while launching creepy
root@io:~# creepy
Traceback (most recent call last):
  File "/usr/bin/creepy", line 19, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebSettings
ImportError: No module named QtWebKit
Steps To Reproducejust do the disc-upgrade
i have tested on freshly installed kali rooling
Additional InformationLibs are missing here if we see the PyQt4 libs
root@io:/usr/lib/python2.7/dist-packages/PyQt4# ls
__init__.py QtGui.x86_64-linux-gnu.so
__init__.pyc QtHelp.x86_64-linux-gnu.so
phonon.x86_64-linux-gnu.so QtNetwork.x86_64-linux-gnu.so
pyqtconfig.py QtOpenGL.x86_64-linux-gnu.so
pyqtconfig.pyc QtScriptTools.x86_64-linux-gnu.so
Qsci.pyi QtScript.x86_64-linux-gnu.so
Qsci.x86_64-linux-gnu.so QtSvg.x86_64-linux-gnu.so
QtAssistant.x86_64-linux-gnu.so QtTest.x86_64-linux-gnu.so
QtCore.x86_64-linux-gnu.so Qt.x86_64-linux-gnu.so
QtDBus.x86_64-linux-gnu.so QtXmlPatterns.x86_64-linux-gnu.so
QtDeclarative.x86_64-linux-gnu.so QtXml.x86_64-linux-gnu.so
QtDesigner.x86_64-linux-gnu.so uic

Activities

dannyrock777

2016-06-06 00:06

reporter   ~0005321

The issue is upgrade is installing python-qt4 (4.11.4+dfsg-2)
and python-qt4 4.11.4+dfsg-2 don't have qwebveiw
Here is the debain package detail qwebveiw is not supported .
https://packages.debian.org/sid/python-qt4
 PyQt4 exposes the Qt4 API to Python. The following modules are supported:

 * QtCore
 * QtDBus
 * QtGui
 * QtNetwork
 * QtXml
 * QtScript
 * QtSvg
 * QtTest
 * QtAssistant
 * QtOpenGL (in python-qt4-gl)
 * QtSql (in python-qt4-sql)
 * phonon (in python-qt4-phonon)

UNATCO

2016-06-06 04:42

reporter   ~0005322

Posted with same problem. Mine's certainly redundant at this point as yours is substantially more detailed.

https://bugs.kali.org/view.php?id=3333

dannyrock777

2016-06-06 09:33

reporter   ~0005325

here is explanation and temporary fix

http://www.shelltutorials.com/bug-in-kali-linux-after-disc-upgrade-spartafern-wifi-crackercreepy-not-working/

sbrun

2016-06-08 08:11

manager   ~0005344

python-qt4 version 4.11.4+dfsg-2kali1 fixes this issue.

Issue History

Date Modified Username Field Change
2016-06-05 10:51 dannyrock777 New Issue
2016-06-06 00:06 dannyrock777 Note Added: 0005321
2016-06-06 04:42 UNATCO Note Added: 0005322
2016-06-06 09:33 dannyrock777 Note Added: 0005325
2016-06-06 13:36 sbrun Assigned To => sbrun
2016-06-06 13:36 sbrun Status new => confirmed
2016-06-08 08:11 sbrun Note Added: 0005344
2016-06-08 08:11 sbrun Status confirmed => resolved
2016-06-08 08:11 sbrun Resolution open => fixed
2016-06-08 08:11 sbrun Fixed in Version => 2016.2