View Issue Details

IDProjectCategoryView StatusLast Update
0000340Kali LinuxKali Package Bugpublic2023-10-10 12:26
Reportervanguard Assigned Torhertzog  
Status closedResolutionfixed 
Platformamd64OSlinuxOS Versiondebian
Summary0000340: live-build crashes due to dependency problem in kali

Dear maintainers,

it is not possible to build kali linux, as live-build crashes due to a dependency problem.

Full log is attached. I tried to add kali-linux manually, then openvas is needed. If would be nice, if you could take a look at that problem and improve the repo.

Thank you very much!

Best regards



has duplicate 0000354 resolved Cannot build CD 




2013-05-04 08:14


binary.log (67,080 bytes)


2013-05-11 09:19

reporter   ~0000452

Actions and results:

  • Action: added entry kali-menu in kali.list.chroot

  • Result: crashes, missing "gsd"

  • Action: added gsd in kali.list.chroot

  • Result: crashes, missing "libopenvas5"

  • Action: added libopenvas5 into kali.list.chroot

  • Result: crashes, missing greenbone-security-assistant, openvas-cli, openvas-manager, openvas-scanner, openvas-administrator.

Also a restart of lb build does NOT work, as it mourns about missing dctl-tools.
This package is installed, but deinstalled during the live-build process.

IMO there is a big, big dependency problem with kali.

Strange: When I chroot into the chroot of live-build, I can easy install all required packagaes with aptitude by hand.

Hope this helps.




2013-05-11 15:49

reporter   ~0000453

I added all required packages for now, but with no success. At the moment, I am stuck! The package openvas needs libopenvas5, but the package gsd wants libopenvas6. So I added them both(!) in kali.list.chroot, but this doesn't work.

It also does not work, to add either libopenvas5 or libopenvas6 into the list.

So I found no trick aka workaround to solve the dependency problem for now. The dependency problem should be solved in the repository somehow.

It would be nice, if you could take a look at it.

Thank you very much!

Best regards




2013-05-15 20:02

reporter   ~0000456

Last edited: 2013-05-15 20:13

Hi Vanguard,

it's the same issue as 0000354, the problem even on a fresh install, before you clone git or build anything, if you try to apt kali-linux-full you get the same errors,

  • kali-linux,
  • openVas,
  • until gsd which installs fine.

When you go back to install openvas again you get a dependency greenbone-security-assistant when I install it, it removes the gsd.

and openvas will again ask for gsd. if you install it again it deletes the greenbone and there the loop stays between these two packages.

ect...which says we have held broken packages which can't be true unless the fresh install is broken.

And you are right btw, the openvas 5 and 6 seems to be needed at the same time. and that seems to be the problem.





2013-05-17 23:17

reporter   ~0000457

Here is a pastebin of my exact steps on a fresh install of kali 32-bit in VMware. Hope this helps with investigation and resolution of this issue! In the meantime I guess I am going back to Backtrack 5 r3



2013-05-23 18:37

reporter   ~0000462

Any idea when this might be fixed or even acknowledged?



2013-06-04 09:56

administrator   ~0000502

The issue was that the updated openvas was partially moved into Kali and some required bits were left in kali-proposed-updates. The remaining packages have been moved to the main repository and the live-build are working fine lately.

At least shows recent builds that succeeded.

Issue History

Date Modified Username Field Change
2013-05-04 08:14 vanguard New Issue
2013-05-04 08:14 vanguard File Added: binary.log
2013-05-11 09:19 vanguard Note Added: 0000452
2013-05-11 15:49 vanguard Note Added: 0000453
2013-05-15 20:02 uofis Note Added: 0000456
2013-05-15 20:03 uofis Note Edited: 0000456
2013-05-15 20:13 uofis Note Edited: 0000456
2013-05-17 23:17 cyb3runkn0wn Note Added: 0000457
2013-05-23 18:37 HMathews Note Added: 0000462
2013-06-04 09:56 rhertzog Note Added: 0000502
2013-06-04 09:56 rhertzog Assigned To => rhertzog
2013-06-04 09:56 rhertzog Status new => resolved
2013-06-04 09:56 rhertzog Resolution open => fixed
2013-06-04 10:01 rhertzog Relationship added has duplicate 0000354
2023-10-10 12:26 vanguard Status resolved => closed