View Issue Details

IDProjectCategoryView StatusLast Update
0000349Kali Linux[All Projects] General Bugpublic2013-07-19 21:27
ReporterDarkSkull Assigned Todookie  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000349: wpscan can't run
DescriptionI noticed that if I run wpscan --url www.somesite.com, I get these errors:
[ERROR] The option: timeout is invalid.
Trace :
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:103:in `block in set_attributes'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:101:in `each_pair'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:101:in `set_attributes'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:86:in `initialize'
/usr/lib/ruby/vendor_ruby/typhoeus/hydra.rb:95:in `new'
/usr/lib/ruby/vendor_ruby/typhoeus/hydra.rb:95:in `initialize'
/usr/share/wpscan/lib/browser.rb:48:in `new'
/usr/share/wpscan/lib/browser.rb:48:in `initialize'
/usr/share/wpscan/lib/browser.rb:62:in `new'
/usr/share/wpscan/lib/browser.rb:62:in `instance'
/usr/share/wpscan/lib/wpscan/wp_target.rb:43:in `initialize'
/usr/bin/wpscan:51:in `new'
/usr/bin/wpscan:51:in `<main>'

Activities

xwei

2013-05-11 03:28

reporter   ~0000451

Last edited: 2013-05-11 03:28

View 2 revisions

me too! my wpscan in kali

targt:

wpscan -url www.xxx.com -e

[ERROR] The option: timeout is invalid.
Trace :
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:103:in `block in set_attributes'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:101:in `each_pair'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:101:in `set_attributes'
/usr/lib/ruby/vendor_ruby/ethon/multi.rb:86:in `initialize'
/usr/lib/ruby/vendor_ruby/typhoeus/hydra.rb:95:in `new'
/usr/lib/ruby/vendor_ruby/typhoeus/hydra.rb:95:in `initialize'
/usr/share/wpscan/lib/browser.rb:48:in `new'
/usr/share/wpscan/lib/browser.rb:48:in `initialize'
/usr/share/wpscan/lib/browser.rb:62:in `new'
/usr/share/wpscan/lib/browser.rb:62:in `instance'
/usr/share/wpscan/lib/wpscan/wp_target.rb:43:in `initialize'
/usr/bin/wpscan:51:in `new'
/usr/bin/wpscan:51:in `<main>'





im very vexed

crossbower

2013-05-25 18:25

reporter   ~0000464

I can not reproduce with version 1.0-11 from our repository.

Please, can you provide your version?

p3ntester

2013-05-30 22:24

reporter   ~0000480

cd ~

sudo apt-get install libcurl4-gnutls-dev libopenssl-ruby libxml2 libxml2-dev libxslt1-dev ruby-dev

git clone https://github.com/wpscanteam/wpscan.git

cd wpscan

sudo gem install bundler && bundle install --without test development

ruby wpscan.rb --url kali.org

xwei

2013-05-31 11:43

reporter   ~0000483



thanks!!!

GrimHacker

2013-06-01 11:18

reporter   ~0000491

same issue.
p3ntester's solution works as a work around.

crossbower, hope this is the information your looking for:

According to the package the version is 1.0-11.
According to the banner the version is v2.0rNA.
(See below)

root@kali:~# dpkg -s wpscan
Package: wpscan
Status: install ok installed
Priority: extra
Section: unknown
Installed-Size: 4147
Maintainer: Mati Aharoni <muts@kali.org>
Architecture: i386
Version: 1.0-11
Depends: ruby1.9.1, rubygems, libcurl4-gnutls-dev, libopenssl-ruby, libxml2, ruby-addressable, ruby-crack, ruby-diff-lcs, ruby-ffi, ruby-json, ruby-mime-types, ruby-nokogiri, ruby-rspec-core, ruby-rspec-expectations, ruby-rspec-mocks, ruby-rspec, ruby-simplecov-html, ruby-ethon, ruby-typhoeus
Description: WPScan is a black box WordPress vulnerability scanner.
 WPScan is a black box WordPress vulnerability scanner.
Homepage: http://www.wpscan.org


root@kali:~# wpscan --help | head -n 11
____________________________________________________
 __ _______ _____
 \ \ / / __ \ / ____|
  \ \ /\ / /| |__) | (___ ___ __ _ _ __
   \ \/ \/ / | ___/ \___ \ / __|/ _` | '_ \
    \ /\ / | | ____) | (__| (_| | | | |
     \/ \/ |_| |_____/ \___|\__,_|_| |_| v2.0rNA

    WordPress Security Scanner by the WPScan Team
 Sponsored by the RandomStorm Open Source Initiative
_____________________________________________________


NOTE: Banner from new clone gives version as v2.1rfc0373f

R4nger

2013-06-02 02:15

reporter   ~0000492

have you tried updating it:)?

GrimHacker

2013-06-04 10:58

reporter   ~0000506

R4nger, yes it doesn't look like package has been updated yet.

CS

2013-06-04 12:42

reporter   ~0000509

Have a look here:
http://bugs.kali.org/view.php?id=53

kimocoder

2013-06-14 14:26

reporter   ~0000558

#!/bin/bash

rm -rf /usr/share/wpscan
git clone git://github.com/wpscanteam/wpscan.git
mv wpscan/ /usr/share/
apt-get update
apt-get install rubygems
gem install terminal-table
gem install --user-install ruby-progressbar

dookie

2013-06-25 22:06

administrator   ~0000594

Fixed in wpscan_2.1+git20130625-1kali0.

Thanks

Issue History

Date Modified Username Field Change
2013-05-10 10:49 DarkSkull New Issue
2013-05-11 03:28 xwei Note Added: 0000451
2013-05-11 03:28 xwei Note Edited: 0000451 View Revisions
2013-05-25 18:25 crossbower Note Added: 0000464
2013-05-25 18:25 crossbower Status new => feedback
2013-05-30 22:24 p3ntester Note Added: 0000480
2013-05-31 11:43 xwei Note Added: 0000483
2013-06-01 11:18 GrimHacker Note Added: 0000491
2013-06-02 02:15 R4nger Note Added: 0000492
2013-06-04 10:58 GrimHacker Note Added: 0000506
2013-06-04 12:42 CS Note Added: 0000509
2013-06-14 14:26 kimocoder Note Added: 0000558
2013-06-25 22:06 dookie Note Added: 0000594
2013-06-25 22:06 dookie Status feedback => resolved
2013-06-25 22:06 dookie Resolution open => fixed
2013-06-25 22:06 dookie Assigned To => dookie