View Issue Details

IDProjectCategoryView StatusLast Update
0003525Kali Linux[All Projects] Kali Package Bugpublic2016-09-05 08:41
Reporterkalimike Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version2016.2 
Summary0003525: apt-get update 404 packages, Kali rolling 2016.1 vm i686
DescriptionPerforming apt-get update results in a list of 404 repos not found errors (All listed in attached screenshot)

All repos have been triple checked and are pointing to the correct locations.
Additional InformationVersion: Kali Rolling 2016.1 vm -i686
Running on windows 10 X64 inside VMWARE Workstation Player 12
GNOME version 3.18.2

Reproduced on three other devices at different locations, Located in Western Australia

Activities

kalimike

2016-09-02 11:44

reporter  

Kali 404.jpg (479,377 bytes)

rhertzog

2016-09-02 13:50

administrator   ~0005738

Last edited: 2016-09-02 13:51

View 2 revisions

I just changed some settings to reassign ftp.ne.jp to Japan (and not Australia). Can you retry now?

Once you retried, I would like to run the commands below and then paste me the whole output you get so that I can try to figure out what's wrong...

host ftp.ne.jp
curl -4 -sI http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/Release
curl -6 -sI http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/Release

echo "deb http://ftp.ne.jp/Linux/packages/kali/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list
apt update

echo "deb http://ftp.halifax.rwth-aachen.de/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list
apt update

rhertzog

2016-09-02 13:52

administrator   ~0005739

Also do you have the same problem with the recently released 2016.2 ISO released recently?

kalimike

2016-09-02 14:26

reporter   ~0005742

Last edited: 2016-09-02 14:27

View 2 revisions

Hi Rhertzog,

Thanks for the quick reply. Unfortunately the errors still appear so I will provide you with the paste of each of those commands.

host ftp.ne.jp:
ftp.ne.jp has address 192.26.91.193
ftp.ne.jp has IPv6 address 2001:200:601:10:206:5bff:fef0:466c
ftp.ne.jp mail is handled by 200 zen.kddilabs.jp.
ftp.ne.jp mail is handled by 100 mandala.kddilabs.jp.

curl -4 -sI http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/Release:
HTTP/1.1 200 OK
Date: Fri, 02 Sep 2016 14:17:45 GMT
Server: Apache/2.4.18 (Unix)
Last-Modified: Fri, 02 Sep 2016 00:05:58 GMT
ETag: "73ad-53b7b1850466c"
Accept-Ranges: bytes
Content-Length: 29613

curl -6 -sI http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/Release:
NO OUTPUT but no error message so I assume success

echo "deb http://ftp.ne.jp/Linux/packages/kali/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list:
NO OUTPUT but no error message so I assume success

apt update:
Ign:1 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling InRelease
Err:2 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling Release
  Unable to connect to :http:
Reading package lists... Done
E: The repository 'http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


echo "deb http://ftp.halifax.rwth-aachen.de/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list:
NO OUTPUT but no error message so I assume success

echo "deb http://ftp.halifax.rwth-aachen.de/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list:
More progress than ever

OUTPUT: Get:1 http://ftp.halifax.rwth-aachen.de/kali kali-rolling InRelease [30.5 kB]
Get:2 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main i386 Packages [13.9 MB]
Get:3 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/contrib i386 Packages [87.1 kB]
Get:4 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/non-free i386 Packages [134 kB]
Fetched 14.1 MB in 47s (297 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
1629 packages can be upgraded. Run 'apt list --upgradable' to see them.

---------------------------------------------------------------------------

To answer your other question no I have not tried the recently released 2016.2 as I have only been using this version. I thought that if the apt-get update was working it would automatically update to that as well. But I am probably wrong. But I have tried this on multiple kali installs which are 2016.1 from memory and all had the same reported error.

I may take 24 hours to reply to future replies as I work during the weekend.

Thanks again!

rhertzog

2016-09-02 14:38

administrator   ~0005745

Do you have working IPv6 configured?

What's the output of the following commands?

ip -6 a
ip -6 r

kalimike

2016-09-02 15:01

reporter   ~0005747

Hi Rhertzog,

I'm very sorry but I've already shut down my system as I'm about to sleep.

I don't use ipv6 so I wouldn't believe that anything would output under that command. I only use IPv4

Thanks again

kalimike

2016-09-03 10:38

reporter   ~0005754

Hi Rhertzog,

The output of ip -6 a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::20c:29ff:fe30:f86c/64 scope link
       valid_lft forever preferred_lft forever

Output of ip -6 r:

fe80::/64 dev eth0 proto kernel metric 256 pref medium

Cheers

rhertzog

2016-09-03 12:07

administrator   ~0005755

Ok, a new set of commands to try to get some more data. First we install strace:

echo "deb http://ftp.halifax.rwth-aachen.de/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list
apt update
apt install strace

Then we put back the problematic configuration and run strace to see what happens at the system calls level:
echo "deb http://ftp.ne.jp/Linux/packages/kali/kali/ kali-rolling main contrib non-free" >/etc/apt/sources.list
strace -f -s 200 -o log apt update
gzip log

And you attach here the "log.gz" file that this process created. Thank you!

kalimike

2016-09-03 12:18

reporter  

log.gz (30,536 bytes)

kalimike

2016-09-03 12:19

reporter   ~0005756

Hi Rhertzog,

Have run above commands and have uploaded the log.gz file to this thread above in the upload file section!

Thank you!!

rhertzog

2016-09-04 13:58

administrator   ~0005760

Thanks, what does "host _http._tcp.ftp.ne.jp" give on your computer?

kalimike

2016-09-04 14:31

reporter   ~0005764

I ran the command host _http._tcp.ftp.ne.jp in terminal. When I pressed enter it just went to a new line and no output. Is this what you needed to know?

rhertzog

2016-09-05 06:07

administrator   ~0005767

Bah, it looks like this behaviour is specific to old apt versions. With the latest apt in kali-rolling and kali 2016.2, the access to the mirror is working.

Can you confirm the version of apt that you are using?

dpkg -s apt | grep Version

kalimike

2016-09-05 07:17

reporter   ~0005768

Version: 1.2.1

Is what came up with that command.

if it isn't fixable, I may download 2016.2 and just tell my colleagues to do the same.

Cheers!

rhertzog

2016-09-05 08:41

administrator   ~0005769

Well, it is fixable by a fix at the DNS level. I pinged the mirror maintainer about it but in the mean time I can only recommend you to use kali 2016.2.

We only ever support our latest release.

Issue History

Date Modified Username Field Change
2016-09-02 11:44 kalimike New Issue
2016-09-02 11:44 kalimike File Added: Kali 404.jpg
2016-09-02 13:50 rhertzog Note Added: 0005738
2016-09-02 13:50 rhertzog Assigned To => rhertzog
2016-09-02 13:50 rhertzog Status new => feedback
2016-09-02 13:51 rhertzog Note Edited: 0005738 View Revisions
2016-09-02 13:52 rhertzog Note Added: 0005739
2016-09-02 14:26 kalimike Note Added: 0005742
2016-09-02 14:26 kalimike Status feedback => assigned
2016-09-02 14:27 kalimike Note Edited: 0005742 View Revisions
2016-09-02 14:38 rhertzog Note Added: 0005745
2016-09-02 15:01 kalimike Note Added: 0005747
2016-09-03 10:38 kalimike Note Added: 0005754
2016-09-03 12:07 rhertzog Note Added: 0005755
2016-09-03 12:18 kalimike File Added: log.gz
2016-09-03 12:19 kalimike Note Added: 0005756
2016-09-04 13:58 rhertzog Note Added: 0005760
2016-09-04 14:31 kalimike Note Added: 0005764
2016-09-05 06:07 rhertzog Note Added: 0005767
2016-09-05 07:17 kalimike Note Added: 0005768
2016-09-05 08:41 rhertzog Note Added: 0005769
2016-09-05 08:41 rhertzog Status assigned => resolved
2016-09-05 08:41 rhertzog Fixed in Version => 2016.2
2016-09-05 08:41 rhertzog Resolution open => no change required