View Issue Details

IDProjectCategoryView StatusLast Update
0000354Kali Linux[All Projects] Kali Package Bugpublic2013-06-04 10:02
Reportercompuwar Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000354: Cannot build CD
DescriptionError on package kali-linux-full trying to build CD with livebuild.
Steps To Reproduceissue "lb build" command
Additional Information[2013-05-15 13:08:33] lb chroot_preseed
P: Begin executing local preseeds...
[2013-05-15 13:08:34] lb chroot_package-lists install
P: Begin queueing installation of package lists (install pass)...
Reading package lists...
Building dependency tree...
Reading state information...
Suggested packages:
  debtags
The following NEW packages will be installed:
  dctrl-tools
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 167 kB of archives.
After this operation, 571 kB of additional disk space will be used.
Get:1 http://archive.kali.org/kali/ kali/main dctrl-tools amd64 2.22.2 [167 kB]
Fetched 167 kB in 1s (149 kB/s)
Selecting previously unselected package dctrl-tools.
(Reading database ... 9317 files and directories currently installed.)
Unpacking dctrl-tools (from .../dctrl-tools_2.22.2_amd64.deb) ...
Processing triggers for man-db ...
Setting up dctrl-tools (2.22.2) ...
Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  dctrl-tools*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 571 kB disk space will be freed.
(Reading database ... 9375 files and directories currently installed.)
Removing dctrl-tools ...
Purging configuration files for dctrl-tools ...
Processing triggers for man-db ...
Reading package lists...
Building dependency tree...
Reading state information...
[2013-05-15 13:08:39] lb chroot_install-packages install
P: Begin installing packages (install pass)...
Reading package lists...
Building dependency tree...
Reading state information...
kali-archive-keyring is already the newest version.
libdb5.1 is already the newest version.
libgcrypt11 is already the newest version.
libgnutls26 is already the newest version.
libgpg-error0 is already the newest version.
libidn11 is already the newest version.
libp11-kit0 is already the newest version.
libsqlite3-0 is already the newest version.
libtasn1-3 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kali-linux-full : Depends: kali-linux but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...
Reading state information...

Relationships

duplicate of 0000340 resolvedrhertzog live-build crashes due to dependency problem in kali 

Activities

vanguard

2013-05-15 17:46

reporter   ~0000455

Please merge this bugreport with issue 000340, as I got the same problem.

Best regards

Hans

cyb3runkn0wn

2013-05-17 23:17

reporter   ~0000458

http://pastebin.com/n0EWpFhw

Here is a pastebin of my exact steps on a fresh install of kali 32-bit in VMware. Hope this helps with investigation and resolution of this issue! In the meantime I guess I am going back to Backtrack 5 r3

rhertzog

2013-06-04 10:02

administrator   ~0000503

The issue was that the updated openvas was partially moved into Kali and some required bits were left in kali-proposed-updates. The remaining packages have been moved to the main repository and the live-build are working fine lately.

At least http://archive.kali.org/kali-daily-images/kali-daily/ shows recent builds that succeeded.

Issue History

Date Modified Username Field Change
2013-05-15 17:11 compuwar New Issue
2013-05-15 17:46 vanguard Note Added: 0000455
2013-05-17 23:17 cyb3runkn0wn Note Added: 0000458
2013-06-04 10:01 rhertzog Relationship added duplicate of 0000340
2013-06-04 10:02 rhertzog Note Added: 0000503
2013-06-04 10:02 rhertzog Status new => resolved
2013-06-04 10:02 rhertzog Resolution open => fixed