2017-09-25 18:37 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003550Kali Linux[All Projects] Kali Package Bugpublic2016-09-20 21:32
ReporterSinderella 
Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version2017.1 
Summary0003550: lightdm/XFCE gui is broken on Hyper-V
DescriptionKali Linux 2016.2 xfce build newly installed on Hyper-V

After I do an `apt update` and `apt upgrade`. Then after a reboot, GUI doesn't load. I tried submiting my user and password, there's a blink and go black screen again.
Steps To Reproduce1. Install Kali 2016.2 xfce build
2. apt update
3. apt upgrade
4. reboot
5. Everything loads fine until GUI starts, screen goes black.
6. Submiting credentials produces a blink, but nothing loads, screen stills empty and black.
Attached Files
  • png file icon xfce.PNG (27,259 bytes) 2016-09-15 20:44 -
    png file icon xfce.PNG (27,259 bytes) 2016-09-15 20:44 +
  • png file icon xfce2.PNG (17,696 bytes) 2016-09-15 20:44 -
    png file icon xfce2.PNG (17,696 bytes) 2016-09-15 20:44 +
  • png file icon xfce3.PNG (8,853 bytes) 2016-09-15 21:07 -
    png file icon xfce3.PNG (8,853 bytes) 2016-09-15 21:07 +
  • txt file icon log1.txt (5,463 bytes) 2016-09-15 21:28 -
    lspci
    00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
    00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
    00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
    00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
    00:08.0 VGA compatible controller: Microsoft Corporation Hyper-V virtual VGA
    00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 20)
    
    -----------------
    
    lsmod |grep hyperv
    hyperv_keyboard 16384 0
    hyperv_fb 20480 1
    hid_hyperv 16384 0
    hid 118784 2 hid_hyperv,hid_generic
    hv_vmbus 90112 6 hyperv_keyboard,hv_netvsc,hid_hyperv,hv_utils,hyperv_fb,hv_storvsc
    
    -----------------
    
    seat0-greeter.log
    ** Message: Starting lightdm-gtk-greeter 2.0.1 (Jun 21 2015, 09:15:25)
    ** Message: [Configuration] Reading file: /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_debian.conf
    ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf
    ** (lightdm-gtk-greeter:1542): WARNING **: [PIDs] Failed to execute command: upstart
    ** (process:1555): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    ** (lightdm-gtk-greeter:1542): WARNING **: [Background] Failed to load background: Failed to open file '/usr/share/images/desktop-base/login-background.svg': No such file or directory
    ** (lightdm-gtk-greeter:1542): WARNING **: [Background] Failed to read wallpaper: /usr/share/images/desktop-base/login-background.svg
    (lightdm-gtk-greeter:1542): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)
    [snip]
    (lightdm-gtk-greeter:1542): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)
    (lightdm-gtk-greeter:1542): Gdk-WARNING **: lightdm-gtk-greeter: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
    
    -----------------
    
    lightdm.log
    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.18.2, UID=0 PID=892
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.00s] DEBUG: Registered seat module xlocal
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.00s] DEBUG: Monitoring logind for seats
    [+0.01s] DEBUG: New seat added from logind: seat0
    [+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.01s] DEBUG: Seat seat0: Starting
    [+0.01s] DEBUG: Seat seat0: Creating greeter session
    [+0.01s] DEBUG: Seat seat0: Creating display server of type x
    [+0.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
    [+0.01s] DEBUG: Using VT 7
    [+0.01s] DEBUG: Seat seat0: Starting local X display on VT 7
    [+0.01s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
    [+0.01s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
    [+0.01s] DEBUG: DisplayServer x-0: Launching X Server
    [+0.01s] DEBUG: Launching process 898: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
    [+0.01s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
    [+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+0.01s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
    [+0.01s] DEBUG: Loading user config from /etc/lightdm/users.conf
    [+0.09s] DEBUG: User debian added
    [+0.43s] DEBUG: Got signal 10 from process 898
    [+0.43s] DEBUG: DisplayServer x-0: Got signal from X server :0
    [+0.43s] DEBUG: DisplayServer x-0: Connecting to XServer :0
    [+0.43s] DEBUG: Seat seat0: Display server ready, starting session authentication
    [+0.43s] DEBUG: Session pid=911: Started with service 'lightdm-greeter', username 'lightdm'
    [+0.44s] DEBUG: Session pid=911: Authentication complete with return value 0: Success
    [+0.44s] DEBUG: Seat seat0: Session authenticated, running command
    [+0.44s] DEBUG: Session pid=911: Running command /usr/sbin/lightdm-gtk-greeter
    [+0.44s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
    [+0.44s] DEBUG: Session pid=911: Logging to /var/log/lightdm/seat0-greeter.log
    [+0.48s] DEBUG: Activating VT 7
    [+0.48s] DEBUG: Activating login1 session c1
    [+0.75s] DEBUG: Greeter connected version=1.18.2 resettable=false
    [+1.30s] DEBUG: Greeter start authentication
    [+1.30s] DEBUG: Session pid=939: Started with service 'lightdm', username '(null)'
    [+1.32s] DEBUG: Session pid=939: Got 1 message(s) from PAM
    [+1.32s] DEBUG: Prompt greeter with 1 message(s)
    [+22.50s] DEBUG: Seat seat0 changes active session to
    
    txt file icon log1.txt (5,463 bytes) 2016-09-15 21:28 +
  • txt file icon log2.txt (8,704 bytes) 2016-09-15 21:28 -
    Package: lightdm-gtk-greeter
    Version: 2.0.1-2
    Installed-Size: 975
    Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
    Architecture: amd64
    Replaces: lightdm (<< 0.9.2-1), lightdm-gtk
    Provides: lightdm-greeter
    Depends: libc6 (>= 2.4), libcairo2 (>= 1.10.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.37.3), libgtk-3-0 (>= 3.9.10), liblightdm-gobject-1-0 (>= 1.8.7), libx11-6
    Recommends: desktop-base, gnome-themes-standard, gnome-icon-theme-symbolic, policykit-1
    Breaks: lightdm (<< 0.9.2-1), lightdm-gtk
    Size: 89830
    SHA256: 4ee18d003d7bf3a690aa88c030746264caa0cc15a9d966080fc0d4234d6ecc30
    SHA1: 486f99cc686df9628615173f194417e2ada7a5d9
    MD5sum: ad37274940f8b6f333390bdde8fc3f10
    Description: simple display manager (GTK+ greeter)
     A LightDM greeter that uses the GTK+ toolkit.
    Description-md5: c095387d293abe3bd155c995649d9b99
    Homepage: https://launchpad.net/lightdm-gtk-greeter
    Tag: role::program, uitoolkit::gtk
    Section: x11
    Priority: optional
    Filename: pool/main/l/lightdm-gtk-greeter/lightdm-gtk-greeter_2.0.1-2_amd64.deb
    
    ----------------------
    
    Package: lightdm
    Version: 1.18.2-2
    Installed-Size: 783
    Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
    Architecture: amd64
    Provides: x-display-manager
    Depends: adduser, dbus, libpam-systemd | consolekit, lightdm-gtk-greeter | lightdm-greeter, debconf (>= 0.5) | debconf-2.0, libaudit1 (>= 1:2.2.1), libc6 (>= 2.14), libgcrypt20 (>= 1.7.0), libglib2.0-0 (>= 2.37.3), libpam0g (>= 0.99.7.1), libxcb1, libxdmcp6
    Recommends: xserver-xorg
    Suggests: accountsservice, upower
    Size: 160764
    SHA256: 5ae44ae282a6a87c7e9e298ef1ee975c167d384afc0af14d5c52076b2f52cd6f
    SHA1: 75a7ed9c462817100cb44bb52471d3d332031b68
    MD5sum: 0b38fa17f546d8f64de74791dcd4f1ac
    Description: simple display manager
     An X display manager that:
      * Has a lightweight codebase
      * Is standards compliant (PAM, ConsoleKit, etc)
      * Has a well defined interface between the server and user interface
      * Fully themeable
      * Cross-desktop (greeters can be written in any toolkit)
    Description-md5: 1fd757fd0b15d99e160ffa78f0717022
    Homepage: https://launchpad.net/lightdm
    Tag: interface::graphical, role::program
    Section: x11
    Priority: optional
    Filename: pool/main/l/lightdm/lightdm_1.18.2-2_amd64.deb
    
    -------------
    
    export
    
    declare -x COLORTERM="xfce4-terminal"
    declare -x DBUS_SESSION_BUS_ADDRESS="unix:path=/run/user/0/bus"
    declare -x DESKTOP_SESSION="xfce"
    declare -x DISPLAY=":1.0"
    declare -x GLADE_CATALOG_PATH=":"
    declare -x GLADE_MODULE_PATH=":"
    declare -x GLADE_PIXMAP_PATH=":"
    declare -x HOME="/root"
    declare -x HUSHLOGIN="FALSE"
    declare -x LANG="en_US.UTF-8"
    declare -x LOGNAME="root"
    declare -x LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:"
    declare -x MAIL="/var/mail/root"
    declare -x OLDPWD
    declare -x PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
    declare -x PWD="/root"
    declare -x QT_ACCESSIBILITY="1"
    declare -x QT_LINUX_ACCESSIBILITY_ALWAYS_ON="1"
    declare -x SESSION_MANAGER="local/kali:@/tmp/.ICE-unix/1420,unix/kali:/tmp/.ICE-unix/1420"
    declare -x SHELL="/bin/bash"
    declare -x SHLVL="2"
    declare -x SSH_AGENT_PID="1410"
    declare -x SSH_AUTH_SOCK="/tmp/ssh-LYzkfU2UQP9Z/agent.1364"
    declare -x TERM="xterm"
    declare -x USER="root"
    declare -x WINDOWID="29360132"
    declare -x WINDOWPATH="1"
    declare -x XAUTHORITY="/root/.Xauthority"
    declare -x XDG_CONFIG_DIRS="/etc/xdg"
    declare -x XDG_CURRENT_DESKTOP="XFCE"
    declare -x XDG_DATA_DIRS="/usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share"
    declare -x XDG_MENU_PREFIX="xfce-"
    declare -x XDG_RUNTIME_DIR="/run/user/0"
    declare -x XDG_SEAT="seat0"
    declare -x XDG_SESSION_ID="5"
    declare -x XDG_VTNR="1"
    
    -------------------
    gtk
    
                  gtk-double-click-time: 400
              gtk-double-click-distance: 5
                       gtk-cursor-blink: TRUE
                  gtk-cursor-blink-time: 1200
               gtk-cursor-blink-timeout: 10
                       gtk-split-cursor: TRUE
                         gtk-theme-name: "Kali-X"
                    gtk-icon-theme-name: "Vibrancy-Kali"
    ! gtk-fallback-icon-theme: NULL
                     gtk-key-theme-name: NULL
                     gtk-menu-bar-accel: "F10"
                 gtk-dnd-drag-threshold: 8
                          gtk-font-name: "Sans 10"
    ! gtk-icon-sizes: NULL
                            gtk-modules: NULL
                      gtk-xft-antialias: 1
                        gtk-xft-hinting: 1
                      gtk-xft-hintstyle: "hintmedium"
                           gtk-xft-rgba: NULL
                            gtk-xft-dpi: 98304
                  gtk-cursor-theme-name: NULL
                  gtk-cursor-theme-size: 0
           gtk-alternative-button-order: FALSE
            gtk-alternative-sort-arrows: FALSE
    ! gtk-show-input-method-menu: FALSE
    ! gtk-show-unicode-menu: FALSE
    ! gtk-timeout-initial: 500
    ! gtk-timeout-repeat: 50
    ! gtk-timeout-expand: 500
    ! gtk-color-scheme: ""
                  gtk-enable-animations: TRUE
    ! gtk-touchscreen-mode: FALSE
    ! gtk-tooltip-timeout: 500
    ! gtk-tooltip-browse-timeout: 60
    ! gtk-tooltip-browse-mode-timeout: 500
    ! gtk-keynav-cursor-only: FALSE
    ! gtk-keynav-wrap-around: TRUE
                         gtk-error-bell: TRUE
    ! color-hash: ((GHashTable*) 0x8ecaa0)
    ! gtk-file-chooser-backend: NULL
                     gtk-print-backends: "file,cups,cloudprint"
              gtk-print-preview-command: "evince --unlink-tempfile --preview --print-settings %s %f"
                   gtk-enable-mnemonics: TRUE
                      gtk-enable-accels: TRUE
    ! gtk-recent-files-limit: 50
                          gtk-im-module: NULL
               gtk-recent-files-max-age: 30
               gtk-fontconfig-timestamp: 0
                   gtk-sound-theme-name: "freedesktop"
       gtk-enable-input-feedback-sounds: TRUE
                gtk-enable-event-sounds: TRUE
    ! gtk-enable-tooltips: TRUE
    ! gtk-toolbar-style: GTK_TOOLBAR_BOTH_HORIZ
    ! gtk-toolbar-icon-size: GTK_ICON_SIZE_LARGE_TOOLBAR
    ! gtk-auto-mnemonics: TRUE
        gtk-primary-button-warps-slider: TRUE
    ! gtk-visible-focus: GTK_POLICY_AUTOMATIC
      gtk-application-prefer-dark-theme: FALSE
    ! gtk-button-images: FALSE
              gtk-entry-select-on-focus: TRUE
        gtk-entry-password-hint-timeout: 0
    ! gtk-menu-images: FALSE
    ! gtk-menu-bar-popup-delay: 0
    ! gtk-scrolled-window-placement: GTK_CORNER_TOP_LEFT
    ! gtk-can-change-accels: FALSE
    ! gtk-menu-popup-delay: 225
    ! gtk-menu-popdown-delay: 1000
              gtk-label-select-on-focus: TRUE
    ! gtk-color-palette: "black:white:gray50:red:purple:blue:light blue:green:yellow:orange:lavender:brown:goldenrod4:dodger blue:pink:light green:gray10:gray30:gray75:gray90"
    ! gtk-im-preedit-style: GTK_IM_PREEDIT_CALLBACK
    ! gtk-im-status-style: GTK_IM_STATUS_CALLBACK
               gtk-shell-shows-app-menu: FALSE
                gtk-shell-shows-menubar: FALSE
                gtk-shell-shows-desktop: TRUE
                  gtk-decoration-layout: "menu:minimize,maximize,close"
              gtk-titlebar-double-click: "toggle-maximize"
              gtk-titlebar-middle-click: "none"
               gtk-titlebar-right-click: "menu"
                 gtk-dialogs-use-header: FALSE
               gtk-enable-primary-paste: TRUE
               gtk-recent-files-enabled: TRUE
                    gtk-long-press-time: 500
                   gtk-keynav-use-caret: FALSE
    txt file icon log2.txt (8,704 bytes) 2016-09-15 21:28 +
  • txt file icon log3.txt (2,270 bytes) 2016-09-15 21:28 -
    xprop
    
    
    _NET_WM_ICON_GEOMETRY(CARDINAL) = 119, 0, 200, 30
    _NET_FRAME_EXTENTS(CARDINAL) = 0, 0, 29, 0
    _NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_CLOSE, _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_MOVE, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_STICK
    WM_STATE(WM_STATE):
                    window state: Normal
                    icon window: 0xaaef4200
    _NET_WM_DESKTOP(CARDINAL) = 0
    _NET_WM_STATE(ATOM) = _NET_WM_STATE_MAXIMIZED_HORZ, _NET_WM_STATE_MAXIMIZED_VERT, _NET_WM_STATE_FOCUSED
    WM_HINTS(WM_HINTS):
                    Client accepts input or input focus: True
                    Initial state is Normal State.
                    bitmap id # to use for icon: 0x1c00022
                    bitmap id # of mask for icon: 0x1c00025
                    window id # of group leader: 0x1c00001
    XdndAware(ATOM) = BITMAP
    _MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
    _NET_WM_ICON(CARDINAL) = Icon (32 x 32):
    _NET_STARTUP_ID(UTF8_STRING) = "xfce4-panel/exo-open/1432-0-kali_TIME758754"
    WM_WINDOW_ROLE(STRING) = "xfce4-terminal-1473973899-1583402794"
    _NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 29360134
    _NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
    _NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x1c00005
    WM_CLIENT_LEADER(WINDOW): window id # 0x1c00001
    _NET_WM_PID(CARDINAL) = 1499
    WM_LOCALE_NAME(STRING) = "en_US.UTF-8"
    WM_CLIENT_MACHINE(STRING) = "kali"
    WM_NORMAL_HINTS(WM_SIZE_HINTS):
                    user specified size: 0 by 0
                    program specified minimum size: 56 by 61
                    program specified resize increment: 10 by 19
                    program specified base size: 16 by 23
                    window gravity: NorthWest
    WM_PROTOCOLS(ATOM): protocols WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
    WM_CLASS(STRING) = "xfce4-terminal", "Xfce4-terminal"
    WM_ICON_NAME(STRING) = "Terminal - root@kali: ~"
    _NET_WM_ICON_NAME(UTF8_STRING) = "Terminal - root@kali: ~"
    WM_NAME(STRING) = "Terminal - root@kali: ~"
    _NET_WM_NAME(UTF8_STRING) = "Terminal - root@kali: ~"
    txt file icon log3.txt (2,270 bytes) 2016-09-15 21:28 +
  • png file icon fixed_packages.PNG (293,346 bytes) 2016-09-18 15:29
  • png file icon post_upgrade_fixed.PNG (13,228 bytes) 2016-09-18 15:30 -
    png file icon post_upgrade_fixed.PNG (13,228 bytes) 2016-09-18 15:30 +

-Relationships
+Relationships

-Notes

~0005797

muts (administrator)

Sorry, not able to reproduce this. Do you have further debugging info you can provide?

~0005798

Sinderella (reporter)

Strange, I'm sorry that is all I did. I did it 2 times by reverting back to the newly installed snapshot, and another time for a new VM.

Is there any other information you want me to provide?

This might be a problem of Hyper-V.

~0005803

Sinderella (reporter)

I've tried installing it on Proxmox with the same image, no problem at all.

Seems like it's Hyper-V :(

~0005902

Razvan (reporter)

Hi!
Can you please try to reinstall kali, and then run apt-get install slim. It will ask you to select a default display manager. Chose slim and it will work.
The reason for this is that lightdm is buggerd. If you want to revert back to lightdm just run dpkg --reconfigure slim and chose lightdm as default.

Hope this helps! :)

~0005935

brokeit (reporter)

Last edited: 2016-09-18 16:35

View 4 revisions

I did a brand new install this morning based off of 2016.2.xfce.amd64. With the default (kali-rolling) repo, I did a full dist-upgrade, rebooted, and it was still broken.

I added the kali-dev repo, did a dist-upgrade (with no other changes) and rebooted. The packages that fixed it are libgtk-3-0 libgtk-3-bin libgtk-3-common gtk-update-icon-cache gir1.2-gtk-3.0.

Once these packages hit kali-rolling, this issue should be resolved.

PS: If you are not familiar with updating screen resolution for Hyper-V, you can update it via grub, like such:
GRUB_CMDLINE_LINUX_DEFAULT="quiet video=hyperv_fb:1280x720"

~0005962

rhertzog (administrator)

iqzer0 and anarchy89, please don't hijack this bug report for unrelated issues on raspberry pi 3. This one is about graphical problems on Hyper-V, microsoft's cloud platform.

~0005966

rhertzog (administrator)

Should be fixed with libgtk-3-0 3.21.6-1~kali1 in kali-rolling now.
+Notes

-Issue History
Date Modified Username Field Change
2016-09-08 13:25 Sinderella New Issue
2016-09-08 13:29 muts Note Added: 0005797
2016-09-08 14:18 Sinderella Note Added: 0005798
2016-09-09 07:26 Sinderella Note Added: 0005803
2016-09-14 06:50 rhertzog Summary Kali Linux 2016.2 xfce build newly installed, `apt upgrade` and after a reboot, GUI's broken => lightdm/XFCE gui is broken on Hyper-V
2016-09-15 20:44 brokeit File Added: xfce.PNG
2016-09-15 20:44 brokeit File Added: xfce2.PNG
2016-09-15 21:04 brokeit Note Added: 0005895
2016-09-15 21:07 brokeit File Added: xfce3.PNG
2016-09-15 21:13 brokeit Note Added: 0005897
2016-09-15 21:14 brokeit Note Edited: 0005895 View Revisions
2016-09-15 21:19 brokeit Note Added: 0005898
2016-09-15 21:19 brokeit Note Edited: 0005898 View Revisions
2016-09-15 21:28 brokeit Note Deleted: 0005898
2016-09-15 21:28 brokeit Note Deleted: 0005895
2016-09-15 21:28 brokeit Note Deleted: 0005897
2016-09-15 21:28 brokeit File Added: log1.txt
2016-09-15 21:28 brokeit File Added: log2.txt
2016-09-15 21:28 brokeit File Added: log3.txt
2016-09-16 05:17 Razvan Note Added: 0005902
2016-09-16 05:44 anarchy89 Note Added: 0005903
2016-09-16 05:49 anarchy89 Note Edited: 0005903 View Revisions
2016-09-16 05:49 anarchy89 Note Edited: 0005903 View Revisions
2016-09-16 05:50 anarchy89 Note Edited: 0005903 View Revisions
2016-09-16 20:37 brokeit Note Added: 0005927
2016-09-18 10:38 brokeit Note Added: 0005935
2016-09-18 15:28 brokeit Note Edited: 0005935 View Revisions
2016-09-18 15:29 brokeit File Added: fixed_packages.PNG
2016-09-18 15:30 brokeit File Added: post_upgrade_fixed.PNG
2016-09-18 15:31 brokeit Note Deleted: 0005927
2016-09-18 16:34 brokeit Note Edited: 0005935 View Revisions
2016-09-18 16:35 brokeit Note Edited: 0005935 View Revisions
2016-09-20 10:40 iqzer0 Note Added: 0005961
2016-09-20 10:56 iqzer0 Note Edited: 0005961 View Revisions
2016-09-20 11:40 rhertzog Note Added: 0005962
2016-09-20 11:58 anarchy89 Note Deleted: 0005903
2016-09-20 14:38 iqzer0 Note Deleted: 0005961
2016-09-20 21:32 rhertzog Note Added: 0005966
2016-09-20 21:32 rhertzog Status new => resolved
2016-09-20 21:32 rhertzog Fixed in Version => 2017.1
2016-09-20 21:32 rhertzog Resolution open => fixed
2016-09-20 21:32 rhertzog Assigned To => rhertzog
+Issue History