2017-10-16 23:44 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003643Kali Linux[All Projects] Kali Package Bugpublic2017-08-12 09:06
Reporter0x90shell 
Assigned Torhertzog 
PrioritynormalSeveritytrivialReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version 
Summary0003643: Repo contains outdated version of xfreerdp-x11
Descriptionxfreerdp in rolling kali repo is version 1.1 and does not support pth functionality. The latest version is 2.0 and does support pth functionality (added in 2014).
Steps To Reproduceroot@Kali:/opt/FreeRDP/client/X11# apt install freerdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'freerdp-x11' instead of 'freerdp'
freerdp-x11 is already the newest version (1.1.0~git20140921.1.440916e+dfsg1-10).
The following package was automatically installed and is no longer required:
  libicu55:i386
Use 'apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 1799 not upgraded.
root@Kali:/opt/FreeRDP/client/X11# xfreerdp -version
This is FreeRDP version 1.1.0-beta1 (git n/a)
root@Kali:/opt/FreeRDP/client/X11# Now here is the latest compiled from github
root@Kali:/opt/FreeRDP/client/X11# ./xfreerdp -version
This is FreeRDP version 2.0.0-dev (git dbb353d)
Attached Files

-Relationships
+Relationships

-Notes

~0006988

rhertzog (administrator)

freerdp 2.x is available in separate binary packages, cf http://pkg.kali.org/pkg/freerdp2 vs http://pkg.kali.org/pkg/freerdp
+Notes

-Issue History
Date Modified Username Field Change
2016-10-03 14:46 0x90shell New Issue
2017-08-12 09:06 rhertzog Assigned To => rhertzog
2017-08-12 09:06 rhertzog Status new => resolved
2017-08-12 09:06 rhertzog Resolution open => fixed
2017-08-12 09:06 rhertzog Note Added: 0006988
+Issue History