2017-12-17 09:55 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003665Kali Linux[All Projects] Kali Package Bugpublic2017-12-05 13:36
Reporterad0nis 
Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version2018.1 
Summary0003665: Polenum not compatible with current python-impacket package included in Kali repos
DescriptionIt appears that the current python-impacket package included in Kali includes "v5" of dcerpc, instead of the v4 that is required for polenum, a package used by enum4linux.


root@kali:~# polenum
Traceback (most recent call last):
  File "/usr/bin/polenum", line 33, in <module>
    from impacket.dcerpc import dcerpc_v4, dcerpc, transport, samr
ImportError: cannot import name dcerpc_v4
Steps To Reproduce1) Install Kali
2) run polenum
3) observe error:

root@kali:~# polenum
Traceback (most recent call last):
  File "/usr/bin/polenum", line 33, in <module>
    from impacket.dcerpc import dcerpc_v4, dcerpc, transport, samr
ImportError: cannot import name dcerpc_v4
Attached Files

-Relationships
+Relationships

-Notes

~0006043

ad0nis (reporter)

If you need a short-term work-around, it's possible to fix this in your own instance by installing the appropriate version of impacket inside a virtualenv.

# download impacket-0.9.11.tar.gz https://pypi.python.org/pypi/impacket/0.9.11
virtualenv polenum
source bin/activate
pip install impacket-0.9.11.tar.gz
# polenum should now work (as long as this virtualenv is active.)

~0007663

sbrun (manager)

fixed in new version 1.4-0kali1
+Notes

-Issue History
Date Modified Username Field Change
2016-10-11 02:35 ad0nis New Issue
2016-10-11 03:34 ad0nis Note Added: 0006043
2017-12-05 13:36 sbrun Status new => resolved
2017-12-05 13:36 sbrun Resolution open => fixed
2017-12-05 13:36 sbrun Fixed in Version => 2018.1
2017-12-05 13:36 sbrun Note Added: 0007663
+Issue History