View Issue Details

IDProjectCategoryView StatusLast Update
0003903Kali Linux[All Projects] General Bugpublic2017-03-07 10:03
Reporterfyzbyt Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version 
Summary0003903: Kali PXE install fails to detect hard drive with $MODULE: disagrees about version of symbol module_layout
DescriptionWhen installing from PXE, Kali fails when detecting hard drives complaining that the kernel doesnt support software RAID devices, then can't load the LVM module.

Dropping into busybox, fdisk -l reveals that the OS can't find any hard drives. Additionally, syslog is full of kernel modules (including raid and lvm) complaining that "$MODULE: disagrees about version of symbol module_layout.
Steps To Reproduce1. Boot kali installer off current PXE boot media.

2. Try to install on a hard drive.

Activities

drush

2017-03-03 00:16

reporter   ~0006460

This appears to be broader than the PXE installation and the hard drive module. When building the kali-rolling ISO, the same issue affects all firmware files. I get the same error for the e1000 network module.

The attach build log indicates it might be something related to the libisofs. See the WARNING messages at the end of the build log. My last successful build was on 2/28/2017.

Booting to the live image works fine, so it seems limited to the installer.

kali-linux-rolling-amd64.log (1,273,181 bytes)

rhertzog

2017-03-03 08:11

administrator   ~0006461

To drush: Those warning messages are not new and they are harmless and completely unrelated to the symbol module_layout problem reported here. Please don't make false speculations when you have no idea what you are talking about.

libisofs: WARNING : Cannot add /firmware/amd64-microcode_3.20160316.3_amd64.deb to Joliet tree. Symlinks can only be added to a Rock Ridge tree.

It would be helpful if you could report the version of the running kernel (uname -a) and the version of the PXE image that you are using. We have updated the kernel twice recently and one of the update was an ABI bump... meaning that the netboot images had to be updated and that older images would no longer work.
But apparently the non-ABI bump did also break the ABI... se we now have to update the netboot images yet another time.

fyzbyt

2017-03-03 16:50

reporter   ~0006463

Kernel version is

Linux kali 4.9.0-kali2-amd64 0000001 SMP Debian 4.9.10-1kali1 (2017-02-20) x86_64 GNU/Linux

I downloaded and updated my PXE install yesterday, before filing this issue, as kernel updates usually bork the installer. It's the first step in troubleshooting.

Unless it's been updated since then, it should be the latest version, but id be happy to pull that information if you can tell me where to look.

rhertzog

2017-03-07 08:38

administrator   ~0006469

We have updated the installer images based on the latest kernel version (4.9.13). Can you download the latest images and try again ? It should be fixed I guess.

sbrun

2017-03-07 10:03

manager   ~0006473

fixed with latest version of installer

Issue History

Date Modified Username Field Change
2017-03-02 23:39 fyzbyt New Issue
2017-03-03 00:16 drush File Added: kali-linux-rolling-amd64.log
2017-03-03 00:16 drush Note Added: 0006460
2017-03-03 08:11 rhertzog Note Added: 0006461
2017-03-03 16:50 fyzbyt Note Added: 0006463
2017-03-07 08:38 rhertzog Assigned To => rhertzog
2017-03-07 08:38 rhertzog Status new => feedback
2017-03-07 08:38 rhertzog Note Added: 0006469
2017-03-07 10:03 sbrun Status feedback => resolved
2017-03-07 10:03 sbrun Resolution open => fixed
2017-03-07 10:03 sbrun Note Added: 0006473