2017-07-26 00:44 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004017Kali Linux[All Projects] General Bugpublic2017-05-16 14:47
Reporterzoneranger 
Assigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0004017: Kali 2017 problem with VMware Workstation
Descriptionkali-linux-2017.1-amd64.iso downloaded, SHA-256 checksum okay.
Used to install a new VM in VMware Workstation 12.5.5 as a guest in Windows.
Click through the installer, reboots to GNOME desktop.
'Shutdown' or 'reboot' at this point and the VM never restarts - massive filesystem corruption or LVM fails to find /dev/mapper/kali--vg-root/

Things I've tried:
Installing without LVM
Installing with LVM but using ext3 and not ext4

I'm aware there is a VMware image but I'm surprised installing from the ISO doesn't seem to produce a working VM. Live install/run is fine - it's the actual install and then reboot, after which the virtual disk seems to be corrupt in a number of ways.
Steps To ReproduceCreate new VM in VMWare Workstation.
Chose custom settings but go for standard CPU, 1 core, 2Gb of RAM, 60Gb disk split into multiple files and not allocated at install which is how I always make VMs. Defaults for SCSI, etc.

Not selecting LVM in the installer seems better but after installing extra packages (such as open-vm-tools-desktop) after boot or rebooting the first time results in file-system corruption.
Attached Files

-Relationships
+Relationships

-Notes

~0006688

Senni (reporter)

Can you confirm the version o workstation, and is the host disk OK? The 'default' options worked ok for myself, shall reinstall with the other options to see if i can re-produce

~0006693

zoneranger (reporter)

It is VMware workstation 12.5.5 build-5234757.
Host disk checks out OK with chkdsk.
Other VMs (including Kali 1) not using systemd and/or ext4 seem okay.
I'm choosing 'Debian 8 (64-bit)' when installing the new VM.

~0006694

Senni (reporter)

What options are you using for the disc, the default scsci ? (just so i can match :D ) , noticed that some of the installs seems to fail so i can poke through and see if i can see anything

~0006698

zoneranger (reporter)

Looking into this further, I've switched to a SATA disk and everything is ok.
Seems to be some conflict between my Dell laptop, VMware 12.x, 4.x Linux kernel and that specific virtual disk type (SCSI). Switching to a different filesystem for the install didn't fix it.
Case closed for now but I guess I can reopen it if I start to see the filesystem corruption - with SCSI virtual disk it was pretty obvious because it would fail after install, updating packages, etc.

~0006700

Senni (reporter)

could be the SCSCI driver that ships with kali maybe? *Takes wild stab in the dark*, as its the default disk type may be worth troubleshooting still :)

~0006701

rhertzog (administrator)

Kali does nothing special to the SCSIĀ driver so this issue should be reported to VMWare I guess. They can then followup with the upstream kernel community if needed.

Anyway closing here on the Kali side as there's nothing we can do currently.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-15 15:10 zoneranger New Issue
2017-05-15 19:46 Senni Note Added: 0006688
2017-05-16 08:34 zoneranger Note Added: 0006693
2017-05-16 09:51 Senni Note Added: 0006694
2017-05-16 13:10 zoneranger Note Added: 0006698
2017-05-16 14:26 Senni Note Added: 0006700
2017-05-16 14:47 rhertzog Assigned To => rhertzog
2017-05-16 14:47 rhertzog Status new => closed
2017-05-16 14:47 rhertzog Resolution open => no change required
2017-05-16 14:47 rhertzog Note Added: 0006701
+Issue History