2017-11-20 03:37 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004081Kali Linux[All Projects] Tool Upgradepublic2017-06-22 07:12
Reporterjesusmmago 
Assigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004081: cewl fails when the URL contains a different port from 80
DescriptionHello there,
I could check that cewl v.5.1 fails to connect when, for example, one tries to run the URL 192.168.22.129:90 on it. This is because the port is 90 and not the typical port 80.
Steps To Reproduceroot@kali:~/Tools# cewl http://192.168.22.129:90 --verbose
CeWL 5.1 Robin Wood (robin@digi.ninja) (http://digi.ninja)

Starting at http://192.168.22.129:90
Visiting: http://192.168.22.129:90, got response code 200
Attribute text found:


Unable to connect to the site, run in verbose mode for more information

The following error may help:
Failed to open TCP connection to 192.168.22.129:80 (Connection refused - connect(2) for "192.168.22.129" port 80)
---------------
Additional InformationI could notice that the last version (cewl 5.2) didn't get the same error and worked fine.
Attached Files

-Relationships
+Relationships

-Notes

~0006840

sbrun (manager)

In Kali-rolling we already have cewl version 5.3-1 (since december 2016)
+Notes

-Issue History
Date Modified Username Field Change
2017-06-16 09:34 jesusmmago New Issue
2017-06-16 09:34 jesusmmago Status new => assigned
2017-06-16 09:34 jesusmmago Assigned To => sbrun
2017-06-21 13:09 sbrun Note Added: 0006840
2017-06-22 07:12 sbrun Status assigned => resolved
2017-06-22 07:12 sbrun Resolution open => fixed
+Issue History