View Issue Details

IDProjectCategoryView StatusLast Update
0004090Kali Linux[All Projects] General Bugpublic2017-07-17 15:25
Reporterrhertzog Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.1 
Target Version2017.2Fixed in Version 
Summary0004090: /etc/network/interfaces refers to wrong interfaces name (ens2p0 instead of eth0)
DescriptionWhen you install a Kali system, /etc/network/interfaces will refer to the interface name seen in the installer. This is the name assigned by systemd/udev.

However in the installed system, we get the files created in the Live ISO to disable that renaming and thus the network interface is known as "eth0" and there's a mismatch which result in the network not working if you don't have Network Manager to configure all known interfaces...

Activities

rhertzog

2017-07-07 10:27

administrator   ~0006874

One solution would be to boot the installer with the kernel parameter "net.ifnames=0". Or to build the various initrd with the same set of files:

# Disable the udev rules renaming the network interfaces (can also be
# achieved with kernel command line net.ifnames=0 but we don't have a nice
# way to set it on the installed system)
mkdir -p /etc/systemd/network /etc/udev/rules.d
ln -sf /dev/null /etc/systemd/network/90-mac-for-usb.link
ln -sf /dev/null /etc/systemd/network/99-default.link
echo > /etc/udev/rules.d/73-special-net-names.rules

rhertzog

2017-07-17 15:25

administrator   ~0006906

Fixed in live-build-config git repository with commit 0bf54092e6ef76ee5d8eff6079b06c927317f58e

I added the --bootappend-install option to set "net.ifnames=0" in the installer kernel command line. This was the most sensible decision since the work to disable that renaming in the installed system is also done in a live-build hook stored in the same repository.

Issue History

Date Modified Username Field Change
2017-07-07 10:16 rhertzog New Issue
2017-07-07 10:16 rhertzog Status new => assigned
2017-07-07 10:16 rhertzog Assigned To => rhertzog
2017-07-07 10:27 rhertzog Note Added: 0006874
2017-07-07 10:27 rhertzog Product Version 2017.2 => 2017.1
2017-07-17 15:25 rhertzog Status assigned => resolved
2017-07-17 15:25 rhertzog Resolution open => fixed
2017-07-17 15:25 rhertzog Note Added: 0006906