2017-11-20 03:36 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004101Kali Linux[All Projects] Kali Package Bugpublic2017-07-19 07:41
ReporterMister_X 
Assigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004101: HostAPd-WPE fails logging credentials for users starting with 5, 6, 7 or 8
DescriptionDue to an error in a configuration file, any user starting with 5, 6, 7 or 8, it wouldn't log credentials as it was defaulting to another authentication method as written in the configuration file itself.

Commenting out those lines, as they should have been, fixes the issue.

A fixed has been pushed in aircrack-ng repository: http://trac.aircrack-ng.org/changeset/2912
Steps To Reproduceapt-get install hostapd-wpe
hostapd-wpe /etc/hostapd-wpe/hostapd-wpe.conf

Login to the 'hostapd-wpe' AP with 612345 as username, it will fail.
Login with 123456, it works fine.
Additional InformationGitHub bug report: https://github.com/aircrack-ng/aircrack-ng/issues/130
Attached Files

-Relationships
+Relationships

-Notes

~0006938

sbrun (manager)

fixed in version 2.6+git20170713-0kali1 in kali-dev
+Notes

-Issue History
Date Modified Username Field Change
2017-07-13 19:28 Mister_X New Issue
2017-07-14 08:37 rhertzog Assigned To => sbrun
2017-07-14 08:37 rhertzog Status new => assigned
2017-07-19 07:41 sbrun Status assigned => resolved
2017-07-19 07:41 sbrun Resolution open => fixed
2017-07-19 07:41 sbrun Note Added: 0006938
+Issue History