View Issue Details

IDProjectCategoryView StatusLast Update
0004190Kali Linux[All Projects] General Bugpublic2017-08-30 07:54
Reporterzlgxzswjy Assigned Torhertzog  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.1 
Target Version2017.2Fixed in Version 
Summary0004190: Bad graphical rendering on VMWare with Linux 4.12 and Wayland, unable to login
DescriptionI update my system use "apt-get update;apt-get upgrade;apt-get dist-upgrade"

when update completed,I find my system kernel changed to 4.12.0 in /boot directory

when I reboot my system , the gdm screen is entirely gray and I can't login.
Steps To Reproduceupdate system kernel to 4.12.0 from 4.11.0

Activities

zlgxzswjy

2017-08-25 06:01

reporter   ~0007133

I installed it in vmware 12.5.7

rhertzog

2017-08-25 07:15

administrator   ~0007135

This is a known bug with "vmwgfx" in Linux 4.12. I'm working on getting a fix. In the mean time, continue to boot into Linux 4.11 (via "Advanced menu" in grub menu) or login to a text console (CTRL+ALT+F3 for example) and change /etc/gdm3/daemon.conf to have "WaylandEnable=false" in the "[daemon]" section.

rhertzog

2017-08-25 13:04

administrator   ~0007144

I uploaded linux 4.12.6-1kali2 with a patch provided by VMWare. The package will take a while to build but tomorrow we should be able to test and ensure that it's fixed.

(It will probably be available in kali-dev in a few hours but kali-rolling will have to wait until tomorrow)

rhertzog

2017-08-25 19:18

administrator   ~0007147

The kernel failed to build so I had to fix some other issues first, the correct version will be 4.12.6-1kali5 and will be a delayed a bit further since the build is just starting.

rhertzog

2017-08-26 07:49

administrator   ~0007150

The new kernel does improve the situation a little bit for me but it's not really that yet. I see all windows elements now but the text that I type is not displayed instantly.

atdtphreaker

2017-08-27 07:14

reporter   ~0007152

@rhertzog

Indeed, there is a slight lag (text).



Thanks.

rhertzog

2017-08-28 22:18

administrator   ~0007162

Some more information: if you enable 3D acceleration in the VM settings, then the work-around patch provided by VMWare is actually working.

But since I have other problems related to Wayland (cf 0004199) I still decided to switch back to Xorg by default for now. This is done with kali-root-login 2017.2.0 and should be available in tomorrow's daily images:
http://archive.kali.org/kali-daily-images/

rhertzog

2017-08-30 07:54

administrator   ~0007183

This is finally fixed with linux 4.12.6-1kali6.

VMWare provided this patch:
https://cgit.freedesktop.org/~syeh/repos_linux/commit/?h=drm-vmwgfx-fixes&id=021aba761f2a6c12158afb9993524c300c01fae2

Issue History

Date Modified Username Field Change
2017-08-25 05:59 zlgxzswjy New Issue
2017-08-25 06:01 zlgxzswjy Note Added: 0007133
2017-08-25 07:15 rhertzog Assigned To => rhertzog
2017-08-25 07:15 rhertzog Status new => assigned
2017-08-25 07:15 rhertzog Target Version => 2017.2
2017-08-25 07:15 rhertzog Summary can't start system when update kernel to 4.12 => Bad graphical rendering on VMWare with Linux 4.12 and Wayland, unable to login
2017-08-25 07:15 rhertzog Description Updated View Revisions
2017-08-25 07:15 rhertzog Note Added: 0007135
2017-08-25 13:04 rhertzog Note Added: 0007144
2017-08-25 19:18 rhertzog Note Added: 0007147
2017-08-26 07:49 rhertzog Note Added: 0007150
2017-08-27 07:14 atdtphreaker Note Added: 0007152
2017-08-28 22:18 rhertzog Note Added: 0007162
2017-08-30 07:54 rhertzog Status assigned => resolved
2017-08-30 07:54 rhertzog Resolution open => fixed
2017-08-30 07:54 rhertzog Note Added: 0007183