View Issue Details

IDProjectCategoryView StatusLast Update
0004377Kali Linux[All Projects] Kali Package Improvementpublic2018-06-25 09:30
ReportersbrunAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.1 
Target VersionFixed in Version2018.1 
Summary0004377: future of ssldump and sslsniff
Descriptionssldump and sslsniff have been removed from Debian testing because they don't compile againt openssl 1.1
They are no more upstream development (or bug fixes) for several years.
As long as openssl1.0 is in Debian testing we can keep these tools in Kali. But it will be removed in future.

Should we remove the packages ssldump and sslsniff or should we try to patch them ourselves so that they compile against openssl 1.1?

Activities

rhertzog

rhertzog

2017-12-04 22:12

administrator   ~0007656

We should try to update them and to keep them working with older protocols too (TLS 1.0, TLS 1.1).
sbrun

sbrun

2018-06-25 09:30

manager   ~0009309

Fixed for:
- sslsniff version 0.8-7 in kali-rolling since march 2018
- ssldump version 0.9b3-7 in kali-rolling since december 2017

Issue History

Date Modified Username Field Change
2017-11-30 14:16 sbrun New Issue
2017-12-04 22:12 rhertzog Note Added: 0007656
2017-12-05 09:54 sbrun Assigned To => sbrun
2017-12-05 09:54 sbrun Status new => assigned
2018-06-25 09:30 sbrun Status assigned => resolved
2018-06-25 09:30 sbrun Resolution open => fixed
2018-06-25 09:30 sbrun Fixed in Version => 2018.1
2018-06-25 09:30 sbrun Note Added: 0009309