View Issue Details

IDProjectCategoryView StatusLast Update
0004479Kali Linux[All Projects] Kali Package Bugpublic2018-07-27 09:10
Reporterlazarus476 Assigned Torhertzog  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.3 
Target VersionFixed in Version 
Summary0004479: Virtual box will not function on Kali 2017.3
DescriptionUpon installing virtualbox 5.2.4 Kernel: 4.14.0-kali3-686-pae (i686), the following errors are ever present and consistent throughout reinstalls, even from the hompage from virtual box. They are covered in "steps to reproduce". I am running an encrypted persistent live boot of kali linux 2017.3. This has taken place after a full update and upgrade of the system.
Steps To Reproduceroot@kali:~# sudo su
root@kali:~# apt-get install virtualbox
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libnotify-bin virtualbox-guest-dkms virtualbox-guest-utils
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  virtualbox-qt
Suggested packages:
  vde2 virtualbox-guest-additions-iso
The following NEW packages will be installed:
  virtualbox virtualbox-qt
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/25.4 MB of archives.
After this operation, 107 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Selecting previously unselected package virtualbox.
(Reading database ... 355339 files and directories currently installed.)
Preparing to unpack .../virtualbox_5.2.4-dfsg-2_i386.deb ...
Unpacking virtualbox (5.2.4-dfsg-2) ...
Selecting previously unselected package virtualbox-qt.
Preparing to unpack .../virtualbox-qt_5.2.4-dfsg-2_i386.deb ...
Unpacking virtualbox-qt (5.2.4-dfsg-2) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-2) ...
Processing triggers for menu (2.1.47+b1) ...
Setting up virtualbox (5.2.4-dfsg-2) ...
vboxweb.service is a disabled or a static unit, not starting it.
Job for virtualbox.service failed because the control process exited with error code.
See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-01-15 00:51:53 UTC; 21ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 14743 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Jan 15 00:51:53 kali systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Jan 15 00:51:53 kali virtualbox[14743]: Loading VirtualBox kernel modules...No suitable module for running kernel found ... failed!
Jan 15 00:51:53 kali virtualbox[14743]: failed!
Jan 15 00:51:53 kali systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Jan 15 00:51:53 kali systemd[1]: virtualbox.service: Failed with result 'exit-code'.
Jan 15 00:51:53 kali systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
Processing triggers for systemd (236-2) ...
Processing triggers for man-db (2.7.6.1-4) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for gnome-menus (3.13.3-11) ...
Processing triggers for hicolor-icon-theme (0.17-1) ...
Setting up virtualbox-qt (5.2.4-dfsg-2) ...
Processing triggers for menu (2.1.47+b1) ...
root@kali:~# virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-686.

     You will not be able to start VMs until this problem is fixed.
Qt WARNING: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
root@kali:~# apt-get install virtualbox-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libnotify-bin virtualbox-guest-dkms virtualbox-guest-utils
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  virtualbox-dkms
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/680 kB of archives.
After this operation, 5,391 kB of additional disk space will be used.
Selecting previously unselected package virtualbox-dkms.
(Reading database ... 355652 files and directories currently installed.)
Preparing to unpack .../virtualbox-dkms_5.2.4-dfsg-2_all.deb ...
Unpacking virtualbox-dkms (5.2.4-dfsg-2) ...
Setting up virtualbox-dkms (5.2.4-dfsg-2) ...
Loading new virtualbox-5.2.4 DKMS files...
Building for 4.13.0-kali1-686-pae 4.14.0-kali3-686-pae
Module build for kernel 4.13.0-kali1-686-pae was skipped since the
kernel headers for this kernel does not seem to be installed.
Building initial module for 4.14.0-kali3-686-pae
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-kali3-686-pae/updates/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-kali3-686-pae/updates/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-kali3-686-pae/updates/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-kali3-686-pae/updates/

depmod...

DKMS: install completed.
Job for virtualbox.service failed because the control process exited with error code.
See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-01-15 00:54:18 UTC; 14ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 18005 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Jan 15 00:54:18 kali systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Jan 15 00:54:18 kali virtualbox[18005]: Loading VirtualBox kernel modules...No suitable module for running kernel found ... failed!
Jan 15 00:54:18 kali virtualbox[18005]: failed!
Jan 15 00:54:18 kali systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Jan 15 00:54:18 kali systemd[1]: virtualbox.service: Failed with result 'exit-code'.
Jan 15 00:54:18 kali systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
root@kali:~# virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-686.

     You will not be able to start VMs until this problem is fixed.
Qt WARNING: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
root@kali:~# apt-get install linux-headers-686
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-686 is already the newest version (4.14+89+kali1).
The following packages were automatically installed and are no longer required:
  libnotify-bin virtualbox-guest-dkms virtualbox-guest-utils
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@kali:~# virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-686.

     You will not be able to start VMs until this problem is fixed.
Qt WARNING: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'

Activities

rhertzog

2018-01-15 13:25

administrator   ~0007814

This is a bit strange as your log shows a successful compilation of the module... can you confirm that /lib/modules/4.14.0-kali3-686-pae/updates/ contains the modules ?

Please run those commands and paste the result:
uname -a
ls -al /lib/modules/4.14.0-kali3-686-pae/updates/

Also what do you see when you run "modprobe vboxdrv" ? Is there an error showing up in kernel messages (check with "dmesg") ?

Please run those commands and paste the result:
modprob vboxdrv
dmesg | tail
lsmod
ls -al /dev/vboxdrv

rhertzog

2018-01-15 13:33

administrator   ~0007815

Hum, your bug report said "Kernel: 4.14.0-kali3-686-pae (i686)" but since you are running a live boot with persistence I guess that you are not running this kernel (which is the latest) but the one that was the latest at the time of the 2017.3 release which was another one...

The output of "uname -a" will quickly reveal this. I'm afraid that you are will have to switch to a newer ISO (a weekly one or the upcoming 2018.1 when it's released) to be able to use virtualbox... because you would need the corresponding linux-headers-<kernel-version> which no longer exists in the repositories.

lazarus476

2018-01-17 05:30

reporter   ~0007824

My sincerest apologies but I scrapped the liveboot and did a full install on my rather old, recently revived laptop, ie, Lazarus, and am not sure I want to test out installing this package simply for the fact the install process for Kali Linux itself was a nightmare (largely due to the fact my USB writer was on the fritz and the laptop is n ancient Dell d610), and if I break something, I wouldn't like to repeat it. Does it matter much now though since the new update will be rolling out soon? Or should I continue with the aforementioned steps?

rhertzog

2018-07-27 09:10

administrator   ~0009388

We have modified our live-build configuration so that the kernel headers are installed by default in the live image and similar discrepancies should no longer be possible in the future.

Issue History

Date Modified Username Field Change
2018-01-15 00:58 lazarus476 New Issue
2018-01-15 13:25 rhertzog Note Added: 0007814
2018-01-15 13:33 rhertzog Assigned To => rhertzog
2018-01-15 13:33 rhertzog Status new => feedback
2018-01-15 13:33 rhertzog Note Added: 0007815
2018-01-17 05:30 lazarus476 Note Added: 0007824
2018-01-17 05:30 lazarus476 Status feedback => assigned
2018-06-22 06:20 g0tmi1k Priority high => normal
2018-07-27 09:10 rhertzog Status assigned => resolved
2018-07-27 09:10 rhertzog Resolution open => fixed
2018-07-27 09:10 rhertzog Note Added: 0009388