View Issue Details

IDProjectCategoryView StatusLast Update
0000464Kali LinuxGeneral Bugpublic2020-12-01 10:48
Reportergvibe06 Assigned Tosteev  
Status resolvedResolutionfixed 
PlatformRaspberry PiOSKaliOS Version1.0
Fixed in Version1.0.5 
Summary0000464: Kali 1.0.4 for Raspberry Pi NO SSH? NO TTY?

Just downloaded and imaged a new SD Card with the Kali v1.0.4 for Raspberry Pi (armel) and I believe that neither SSH nor TTY is enabled by default.

$ ssh [email protected]
ssh: connect to host port 22: Connection refused

$ ping -c 4
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=1.315 ms
64 bytes from icmp_seq=1 ttl=64 time=0.802 ms
64 bytes from icmp_seq=2 ttl=64 time=1.031 ms
64 bytes from icmp_seq=3 ttl=64 time=0.814 ms

--- ping statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.802/0.990/1.315/0.208 ms

$ arp -n -a
? ( at b8:27:eb:b7:50:2f on en0 ifscope [ethernet]

Tried connecting via Minicom and I get no response via Serial either.

Steps To Reproduce
  1. dd image to SD Card then boot your Raspberry Pi.

  2. Try to ssh to the Pi.

  3. Try connecting via Serial.

  4. Both fail.

Additional Information

You must know that most Raspberry Pi's do not come with any sort of monitor or keyboard, so we kind of need at the very least Serial capabilities to login for the first time.

NOTE: v1.0.0 did not have this problem




2013-07-30 14:47

manager   ~0000655

I'll fix this and get a new image up soon, until then, you can edit /etc/inittab on the sdcard and add at the bottom:

T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

SSH however is disabled by default on all Kali installations, so you'll need to login either on serial, or add a keyboard and monitor to the rpi, and run dpkg-reconfigure openssh-server to generate new ssh keys (due to openssh on debian generating keys when being installed we remove the keys before making the image otherwise every rpi out there would have the same ssh keys) and then run

update-rc.d ssh enable (to enable the service at boot time)
service ssh start (to start the service)



2013-08-21 18:48

reporter   ~0000778

I ran into this problem and have a suggestion. I also do not use keyboard, mouse or serial to access my pi.

My suggestion - can you enable Telnet for a "first run" instance. In this way telent can be used to configure SSH and disable telnet.



2013-09-05 18:12

manager   ~0000824

Thanks for the report, we've enabled ssh for the rpi image. It is HIGHLY recommended that after the first time you connect that you change your ssh keys as all rpi images will have the same keys.

Issue History

Date Modified Username Field Change
2013-07-28 03:58 gvibe06 New Issue
2013-07-30 14:47 steev Note Added: 0000655
2013-07-30 14:47 steev Assigned To => steev
2013-07-30 14:47 steev Status new => assigned
2013-07-31 13:34 steev Status assigned => confirmed
2013-08-21 18:48 asmallri Note Added: 0000778
2013-09-05 18:12 steev Note Added: 0000824
2013-09-05 18:12 steev Status confirmed => resolved
2013-09-05 18:12 steev Fixed in Version => 1.0.5
2013-09-05 18:12 steev Resolution open => fixed
2013-09-21 05:11 thrasher12ga Issue cloned: 0000603
2020-12-01 10:48 g0tmi1k Priority high => normal