View Issue Details

IDProjectCategoryView StatusLast Update
0004653Kali Linux[All Projects] General Bugpublic2022-07-18 07:14
Reportercoolaayush22 Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
Product Version2018.1 
Target VersionFixed in Version 
Summary0004653: [REPOS] Repository is missing DEP-11 / appstream metadata
Descriptionwhen ever i launch my gnome software all i can see is extensions ...... i have updated my packages ..upgraded packages and distribution ...but it doesn't work at all

Activities

coolaayush22

2018-03-25 10:46

reporter  

rhertzog

2018-03-28 07:48

administrator   ~0008967

I believe that the reason is the lack of appstream metadata in Kali repositories:
https://www.freedesktop.org/wiki/Distributions/AppStream/
http://dep.debian.net/deps/dep11/

Debian repositories have this. But we are using reprepro to manage the repository and it doesn't offer this feature currently.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824521

silopolis

2022-07-09 16:38

reporter   ~0016375

Hello friends,

Upping this one with a KDE Discover screenshot demonstrating the same issue.

I added comments in both Debian bug discussion and aptly's issue on GH (https://github.com/aptly-dev/aptly/pull/473) in the hope it will revive will to improve the situation.

@rhertzog like said there, don't know what the amount would be, but again I'd gladly help funding the resolution of this here and anywhere upstream. Kali is AFAIC the very best Debian based KDE workstation OS and this one is a pain for UX.

Thanks for all the amazing work folks. Have a beautiful WE :)

PS: Can't Kali infrastructure make use of appstream-generator on its own without depending on repository management software ? As I understand it, it looks like KDE Neon is doing so with Aptly: https://community.kde.org/Neon/Appstream

rhertzog

2022-07-18 07:14

administrator   ~0016398

At some point the appstream files must be recorded in the "Release" file managed by reprepro. There might be ways to script a change to this file with some hook but it's non trivial (and nobody has done it yet on the Kali side).

Issue History

Date Modified Username Field Change
2018-03-25 10:46 coolaayush22 New Issue
2018-03-25 10:46 coolaayush22 File Added: Screenshot from 2018-03-24 23-16-57.png
2018-03-28 07:34 sbrun Assigned To => rhertzog
2018-03-28 07:34 sbrun Priority immediate => normal
2018-03-28 07:34 sbrun Status new => confirmed
2018-03-28 07:34 sbrun Summary gnome software starts and does not show any softwares in it => Repository is missing metadata
2018-03-28 07:48 rhertzog Note Added: 0008967
2018-05-08 07:59 g0tmi1k Category Kali Package Bug => General Bug
2018-06-08 16:01 g0tmi1k Severity crash => minor
2018-09-12 07:58 g0tmi1k Summary Repository is missing metadata => [REPOS] Repository is missing metadata
2018-11-23 13:02 rhertzog Summary [REPOS] Repository is missing metadata => [REPOS] Repository is missing DEP-11 / appstream metadata
2019-09-04 12:36 g0tmi1k Status confirmed => closed
2019-09-04 13:32 rhertzog Status closed => assigned
2022-07-09 16:38 silopolis File Added: Screenshot_20220709_182757.png
2022-07-09 16:38 silopolis Note Added: 0016375
2022-07-18 07:14 rhertzog Note Added: 0016398
2022-07-24 20:16 Condom Issue cloned: 0007816