2018-10-22 03:04 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004720Kali Linux[All Projects] Kali Package Bugpublic2018-05-03 12:01
Reporterpkreuzt 
Assigned Tosbrun 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2018.3 
Summary0004720: cannot use idb package due to dependency conflict
DescriptionTrying to install idb package, it needs ruby-hexdump (among others) as a dependency. But ruby-hexdump conflicts with ruby-httpclient, which is a dependency to urlcrazy, kali-linux-all and kali-linux-full packages, and renders idb unusable. Dpkg error message:

Preparando para desempaquetar .../ruby-hexdump_0.2.3-0kali1_all.deb ...
Desempaquetando ruby-hexdump (0.2.3-0kali1) ...
dpkg: error al procesar el archivo /var/cache/apt/archives/ruby-hexdump_0.2.3-0kali1_all.deb (--unpack):
 intentando sobreescribir `/usr/lib/ruby/vendor_ruby/hexdump.rb', que está también en el paquete ruby-httpclient 2.8.3-1
Se encontraron errores al procesar:
 /var/cache/apt/archives/ruby-hexdump_0.2.3-0kali1_all.deb

Attached Files

-Relationships
+Relationships

-Notes

~0009086

sbrun (manager)

conflict file issue is fixed with idb version 2.10.3-0kali2: we don't use ruby-hexdump anymore but hexdump from ruby-httpclient.
Could you test idb to be sure that we don't break something else?

~0009088

pkreuzt (reporter)

idb version 2.10.3-0kali2 installs and runs without errors, at least as far as I have tested it. Good job. :-)
+Notes

-Issue History
Date Modified Username Field Change
2018-04-27 20:54 pkreuzt New Issue
2018-04-30 06:59 sbrun Assigned To => sbrun
2018-04-30 06:59 sbrun Status new => assigned
2018-05-03 09:10 sbrun Status assigned => feedback
2018-05-03 09:10 sbrun Note Added: 0009086
2018-05-03 11:20 pkreuzt Note Added: 0009088
2018-05-03 11:20 pkreuzt Status feedback => assigned
2018-05-03 12:01 sbrun Status assigned => resolved
2018-05-03 12:01 sbrun Resolution open => fixed
2018-05-03 12:01 sbrun Fixed in Version => 2018.3
+Issue History