View Issue Details

IDProjectCategoryView StatusLast Update
0004876Kali Linux[All Projects] Kali Package Bugpublic2018-08-23 06:31
ReporterMister_XAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.2 
Target VersionFixed in Version2018.4 
Summary0004876: Pyrit fails with "AttributeError: 'module' object has no attribute 'EAPOL'"
DescriptionRunning pyrit on a monitor mode interface with stripLive crashes:

pyrit -r wpa2.eapol.cap analyze
Pyrit 0.5.1 (C) 2008-2011 Lukas Lueg - 2015 John Mora
https://github.com/JPaulMora/Pyrit
This code is distributed under the GNU General Public License v3+

Traceback (most recent call last):
  File "/usr/bin/pyrit", line 6, in <module>
    pyrit_cli.Pyrit_CLI().initFromArgv()
  File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 118, in initFromArgv
    func(self, **options)
  File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 161, in new_f
    import cpyrit.pckttools
  File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 132, in <module>
    scapy.packet.bind_layers(scapy.layers.l2.EAPOL, EAPOL_Key, type=3)
AttributeError: 'module' object has no attribute 'EAPOL'

The issue is known and downgrading scapy seems to be the solution: https://github.com/JPaulMora/Pyrit/issues/558

Activities

Mister_X

2018-08-01 02:06

reporter   ~0009413

This PR fixes the issue: https://github.com/JPaulMora/Pyrit/pull/574

usama

2018-08-01 03:56

reporter   ~0009414

pyrit throws same error when using "pyrit -r XX:XX:XX:XX:XX:XX.cap analyze".Downgrading scapy to 2.3 fixes the problem.

Mister_X

2018-08-01 16:43

reporter   ~0009416

PR has been merged. @usama, just get the latest git and you won't have to downgrade scapy

usama

2018-08-02 02:01

reporter   ~0009417

@Mister_X I replaced the problematic with the fixed one (pckttools.py) and now pyrit works fine with scapy 2.4

rhertzog

2018-08-20 14:39

administrator   ~0009479

It looks like we should package a new git snapshot then.

sbrun

2018-08-23 06:31

manager   ~0009497

fixed in new version 0.5.1+git20180801-0kali1

Issue History

Date Modified Username Field Change
2018-07-31 22:06 Mister_X New Issue
2018-08-01 02:06 Mister_X Note Added: 0009413
2018-08-01 03:56 usama Note Added: 0009414
2018-08-01 16:43 Mister_X Note Added: 0009416
2018-08-02 02:01 usama Note Added: 0009417
2018-08-18 18:59 elwood Status new => acknowledged
2018-08-20 14:38 rhertzog Assigned To => sbrun
2018-08-20 14:38 rhertzog Status acknowledged => assigned
2018-08-20 14:39 rhertzog Note Added: 0009479
2018-08-23 06:31 sbrun Status assigned => resolved
2018-08-23 06:31 sbrun Resolution open => fixed
2018-08-23 06:31 sbrun Fixed in Version => 2018.4
2018-08-23 06:31 sbrun Note Added: 0009497