View Issue Details

IDProjectCategoryView StatusLast Update
0004921Kali Linux[All Projects] General Bugpublic2018-08-21 12:40
Reporterdadianton Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0004921: Kali PXE install fails on debootstrap - no script found for kali-rolling
DescriptionWhen installing kali via PXE the installer fails during the base install step.

It fails when debootstrap attempts to call the kali-rolling script which does not exist in /usr/share/debootstrap/scripts/kali-rolling. I see other scripts there but no kali-rolling.

The exact error message is included in a screenshot. (see file)

I run my installs against a local mirror so that is why the target of debootstrap is pointing to a local private IP.

Relationships

has duplicate 0004920 closedrhertzog Kali PXE install fails on debootstrap - no script found for kali-rolling 

Activities

dadianton

2018-08-20 18:44

reporter  

debootstrap_error-min.jpg (1,457,559 bytes)

rhertzog

2018-08-21 10:39

administrator   ~0009486

This is likely a consequence of this change made in debootstrap:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893713

Our kali-rolling script has been dropped from the debootstrap udeb built by Debian. I will build our own udeb until this gets fixed.

rhertzog

2018-08-21 12:40

administrator   ~0009487

debootstrap-udeb 1.0.108kali1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2018-08-20 18:44 dadianton New Issue
2018-08-20 18:44 dadianton File Added: debootstrap_error-min.jpg
2018-08-21 10:28 rhertzog Relationship added has duplicate 0004920
2018-08-21 10:39 rhertzog Assigned To => rhertzog
2018-08-21 10:39 rhertzog Status new => assigned
2018-08-21 10:39 rhertzog Note Added: 0009486
2018-08-21 12:40 rhertzog Status assigned => resolved
2018-08-21 12:40 rhertzog Resolution open => fixed
2018-08-21 12:40 rhertzog Note Added: 0009487