View Issue Details

IDProjectCategoryView StatusLast Update
0004936Kali Linux[All Projects] General Bugpublic2018-11-23 11:16
Reporterkalibugs2Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionnot fixable 
Product Version2018.2 
Target VersionFixed in Version 
Summary0004936: Audio doesn't work anymore after Kali dist-upgrade to 2018.3
DescriptionMy audio doesn't work anymore after I did upgrade Kali.

Card: HDA Intel PCH Chip: Realtek ALC270

lspci:

00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

Audio control panel shows me a "dummy device" only.

Thanks

Activities

elwood

2018-08-31 00:42

administrator   ~0009554

We're sorry but we don't have the manpower to deal with hardware support problems.
Those problems need to be fixed in the upstream Linux kernel. We regularly import new kernel releases.

Don't buy hardware from suppliers who don't care about their Linux support.

kalibugs2

2018-08-31 08:29

reporter   ~0009560

Hi
I used my laptop for more than 7 years and I always used backtrack and kali without problems. My audio stopped to work after I upgraded to Kali 2018.3
In my opinion is not a hardware problem (because I see my audio device) but a pulseaudio/alsa conf problem.
I'm trying to purge pulseaudio but I'm unable to to this without removing other core packages:

The following packages will be REMOVED:
  gnome-core gqrx-sdr kali-desktop-gnome libcanberra-pulse pulseaudio pulseaudio-module-bluetooth

Please let me know, thank you

rhertzog

2018-08-31 11:04

administrator   ~0009562

The hardware is certainly not a fault, but it might be kernel driver regression, a problem in pulseaudio, or whatever else.

Unfortunately, we are not the upstream developers of the kernel and of pulseaudio and we don't have the resources to investigate the problem for you. We can handle bug reports that pin-point a problem that we introduced or apply some upstream patches that advanced users have found.

Your request is outside of what we can handle, sorry.

kalibugs2

2018-09-01 20:49

reporter   ~0009574

I think it's not a kernel regression bug.
I was able to play audio as root user only doing this:

pulseaudio --kill; pulseaudio --start (as no root user)
mplayer file.mp3 (as root)

When instead I tried to play audio as a no root user I got:

Audio device got stuck! (and no sound)

kalibugs2

2018-09-01 20:53

reporter   ~0009575

I followed a partial solution that I found for another Kali audio bug: https://bugs.kali.org/view.php?id=4384 and I got audio also for no-root users:

pulseaudio --kill; pulseaudio -D

rhertzog

2018-09-02 08:42

administrator   ~0009576

So basically you have to restart pulseaudio. pulseaudio is correctly auto-started for root and for non-root.

It doesn't change much from my point of view. We haven't made any change at the pulseaudio level, so either it's a pulseaudio bug or it's a kernel bug (which can be worked-around by restarting pulseaudio).

Now if you really want to go further, you should try to see if rebooting with the former kernel helps. Or if downgrading pulseaudio to a former version helps. Your logs in /var/log/apt should help you to find out what got upgraded and what were the versions before.

rhertzog

2018-11-23 11:16

administrator   ~0009976

No further information has been provided. There's nothing we can do about this issue.

Issue History

Date Modified Username Field Change
2018-08-28 09:46 kalibugs2 New Issue
2018-08-31 00:42 elwood Status new => closed
2018-08-31 00:42 elwood Resolution open => unable to reproduce
2018-08-31 00:42 elwood Note Added: 0009554
2018-08-31 08:29 kalibugs2 Status closed => feedback
2018-08-31 08:29 kalibugs2 Resolution unable to reproduce => reopened
2018-08-31 08:29 kalibugs2 Note Added: 0009560
2018-08-31 11:04 rhertzog Note Added: 0009562
2018-08-31 11:04 rhertzog Assigned To => rhertzog
2018-08-31 11:04 rhertzog Status feedback => closed
2018-08-31 11:04 rhertzog Resolution reopened => not fixable
2018-09-01 20:49 kalibugs2 Status closed => feedback
2018-09-01 20:49 kalibugs2 Resolution not fixable => reopened
2018-09-01 20:49 kalibugs2 Note Added: 0009574
2018-09-01 20:53 kalibugs2 Note Added: 0009575
2018-09-01 20:53 kalibugs2 Status feedback => assigned
2018-09-02 08:42 rhertzog Note Added: 0009576
2018-11-23 11:16 rhertzog Status assigned => resolved
2018-11-23 11:16 rhertzog Resolution reopened => not fixable
2018-11-23 11:16 rhertzog Note Added: 0009976