View Issue Details

IDProjectCategoryView StatusLast Update
0004958Kali Linux[All Projects] Kali Package Improvementpublic2018-09-13 11:13
ReportertjnullAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2018.3 
Target VersionFixed in Version2018.4 
Summary0004958: Powershell will not run without libcurl3
DescriptionRecently Kali is now using libcurl4 for its programs such as Metasploit. When you go through the instruction to install powershell you receive the following:

root@kali:~# apt -y install powershell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 powershell : Depends: libcurl3 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



When trying to install libcurl3 we get the following message:

root@kali:~# apt-get install libcurl3
Reading package lists... Done
Building dependency tree
Reading state information... Done

The following packages will be REMOVED:
  curl libcurl4 metasploit-framework
The following NEW packages will be installed:
  libcurl3
0 upgraded, 1 newly installed, 3 to remove and 0 not upgraded.
Need to get 260 kB of archives.
After this operation, 250 MB disk space will be freed.


Suggesting to have powershell update to libcurl4 for future use in Kali Linux

Activities

usama

usama

2018-09-06 14:28

reporter   ~0009595

same here
rhertzog

rhertzog

2018-09-06 19:11

administrator   ~0009596

But powershell is not provided by Debian or Kali, so there's not much that we can do here unless we package it for Kali (in that case it would be compiled with the correct library versions).
tjnull

tjnull

2018-09-10 11:02

reporter   ~0009622

I submitted this issue to powershell on github to see if they can help but powershell for Kali is only supported by the Kali community not them.

They also stated that PowerShell Core no longer has a dependency on libcurl #6964. However, even when you download the latest powershell package from github it still states libcurl3 is required.

Attached Github issue I have reported:
https://github.com/PowerShell/PowerShell/issues/7719
SecurityWaffle

SecurityWaffle

2018-09-10 13:26

reporter   ~0009624

The below package does not have the libcurl3 requirement and works with libcurl4:

powershell-preview/stretch,now 6.1.0~rc.1-1.debian.9 amd64
tjnull

tjnull

2018-09-10 13:41

reporter   ~0009625

Testing that now @securitywaffle
tjnull

tjnull

2018-09-10 13:50

reporter   ~0009626

Hmm that did not work either when I downloaded in from stretch. Gonna try the other two versions

root@DKali:~/Desktop# dpkg -i powershell-preview_6.1.0~rc.1-1.deb
(Reading database ... 449539 files and directories currently installed.)
Preparing to unpack powershell-preview_6.1.0~rc.1-1.deb ...
Unpacking powershell-preview (6.1.0~rc.1-1.debian.9) over (6.1.0~rc.1-1.debian.9) ...
Setting up powershell-preview (6.1.0~rc.1-1.debian.9) ...
Processing triggers for man-db (2.8.4-2) ...

root@Kali:~/Desktop# pwsh
bash: pwsh: command not found
tjnull

tjnull

2018-09-10 16:53

reporter   ~0009629

Alright so I tested all of the powershell/powershell preview packages in jessie and stretch.

The powershell packages in jessie and in stretch all failed because they need libcurl3 to install. However, the powershell preview packages in jessie and stretch actually worked and did not need libcurl3 to install.

In case you want to install powershell I recommend to use this package: powershell-preview_6.1.0~preview.3-1.deb

Link: https://packages.microsoft.com/repos/microsoft-debian-jessie-prod/pool/main/p/powershell-preview/

Once you have installed the package you can then update it to powershell-preview_6.1.0~rc.1-1.deb.

Do not try to install powershell-preview_6.1.0~rc.1-1.deb without 3-1.deb (For some reason rc.1-1 would install but when you execute "pwsh" to run powershell it would fail).

I am attaching the results that I have done for all of the debian powershell packages as proof and hopefully Microsoft will give us an update on why the actual packages are still supporting libcurl3.

I hope this helps for now :D.

-TJNull

Powershell Package Results.zip (4,259 bytes)
SecurityWaffle

SecurityWaffle

2018-09-10 17:18

reporter   ~0009634

pwsh-preview is the command for the version of powershell I recommended.
SecurityWaffle

SecurityWaffle

2018-09-10 17:55

reporter   ~0009635

@TJNull, If I recall correctly, Powershell Core 6.0 depends on dotnet core 2.0 which doesn't support libcurl4. Powershell Core 6.1 was moved to dotnet core 2.1.1 which requires libcurl4 and this change was never backported.
tjnull

tjnull

2018-09-10 18:03

reporter   ~0009636

@securitywaffle I did not know you could do pwsh-preview and I will go through the testing again for the preview packages but I think they should both work.

Here is also what I got from microsoft about libcurl:

PSCore6.0.x depends on .NET Core 2.0.x which DOES depend on libcurl. PSCore6.1 depends on .NET Core 2.1.x which does NOT depend on libcurl.

So I am still trying to understand why does the debian packages ask for libcurl3 and not libcurl4?
tjnull

tjnull

2018-09-11 12:33

reporter   ~0009638

Re-ran the tests for powershell preview packages from Jessie and Stretch and they work fine on Kali Linux 2018.3.

Attached Results below:

Powershell Preview Results 09.11.2018.zip (1,570 bytes)
fl0

fl0

2018-09-13 07:57

reporter   ~0009714

Issue resolved with version 6.1.0-1.debian.9 updated today.
tjnull

tjnull

2018-09-13 11:08

reporter   ~0009715

@fl0 Verified and confirmed the updated powershell works now in Kali Linux:

Both packages in Stretch and Jessie work on Kali 2018.3

Stretch:powershell_6.1.0-1.deb 13-Sep-2018 00:34 58286110
Jessie:powershell_6.1.0-1.deb 13-Sep-2018 00:33 58287274

Issue History

Date Modified Username Field Change
2018-09-06 14:02 tjnull New Issue
2018-09-06 14:28 usama Note Added: 0009595
2018-09-06 19:11 rhertzog Assigned To => rhertzog
2018-09-06 19:11 rhertzog Status new => feedback
2018-09-06 19:11 rhertzog Note Added: 0009596
2018-09-10 11:02 tjnull Note Added: 0009622
2018-09-10 11:02 tjnull Status feedback => assigned
2018-09-10 13:26 SecurityWaffle Note Added: 0009624
2018-09-10 13:41 tjnull Note Added: 0009625
2018-09-10 13:50 tjnull Note Added: 0009626
2018-09-10 16:53 tjnull File Added: Powershell Package Results.zip
2018-09-10 16:53 tjnull Note Added: 0009629
2018-09-10 17:18 SecurityWaffle Note Added: 0009634
2018-09-10 17:55 SecurityWaffle Note Added: 0009635
2018-09-10 18:03 tjnull Note Added: 0009636
2018-09-11 12:33 tjnull File Added: Powershell Preview Results 09.11.2018.zip
2018-09-11 12:33 tjnull Note Added: 0009638
2018-09-13 07:57 fl0 Note Added: 0009714
2018-09-13 11:08 tjnull Note Added: 0009715
2018-09-13 11:13 rhertzog Status assigned => resolved
2018-09-13 11:13 rhertzog Resolution open => no change required
2018-09-13 11:13 rhertzog Fixed in Version => 2018.4