View Issue Details

IDProjectCategoryView StatusLast Update
0004967Kali Linux[All Projects] Kali Package Bugpublic2018-11-28 07:50
ReportertjbAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Product Version2018.3 
Target VersionFixed in Version 
Summary0004967: openvassd SIGSEGV
DescriptionOpenvas scans stop at 1% complete, openvas-scanner log shows the following:

SIGSEGV occured !
openvassd: Serving /var/run/openvassd.sock(sighand_segv+0x81)[0x5595242fce11]
/lib/x86_64-linux-gnu/libc.so.6(+0x35fc0)[0x7fced8f95fc0]
/lib/x86_64-linux-gnu/libc.so.6(+0x3a850)[0x7fced8f9a850]
/usr/lib/x86_64-linux-gnu/libopenvas_base.so.9(nvticache_get_category+0x30)[0x7fced97f2050]
openvassd: Serving /var/run/openvassd.sock(plugins_scheduler_init+0x68)[0x5595242fba28]
openvassd: Serving /var/run/openvassd.sock(attack_network+0x239)[0x5595242f6499]
openvassd: Serving /var/run/openvassd.sock(+0xb4cc)[0x5595242f94cc]
openvassd: Serving /var/run/openvassd.sock(create_process+0xb7)[0x5595242fcbe7]
openvassd: Serving /var/run/openvassd.sock(+0xbf80)[0x5595242f9f80]
openvassd: Serving /var/run/openvassd.sock(main+0x37f)[0x5595242f50cf]
[Sun Sep 9 03:57:36 2018][7827] Received the Terminated signal

Activities

tjb

tjb

2018-10-23 01:48

reporter   ~0009827

The openvas-scanner version is 5.1.3-2

I've tried downloading the scanner source code from the openvas site and building it, and hit the same issue. As part of that process, I removed all of the vulnerability data, re-fetched it, and rebuilt the cache.
tjb

tjb

2018-10-23 01:50

reporter   ~0009828

For me, this is not a minor issue, as it makes openvas completely unusable.
I have access to previous scan reports only.
tjb

tjb

2018-11-26 01:44

reporter   ~0009994

I found a workaround or solution, which pointed me to redis as the issue.

Solution is run:
  redis-cli -s /var/run/redis-openvas/redis-server.sock flushall

I then restarted redis, not sure if that is necessary, and openvas is running normally.
fearx135

fearx135

2018-11-27 23:58

reporter   ~0010027

According to the greenbone site (https://community.greenbone.net/t/community-feed-unusable/132/7) the issue occurs for an because there is a problem in the openvas 5.1.3 scanner, they already fixed the issue and needs to be compiled for Kali:

https://github.com/greenbone/openvas-scanner/pull/155/files (bug fix)
https://github.com/greenbone/openvas-scanner/releases/tag/v5.1.3 (update)
rhertzog

rhertzog

2018-11-28 07:50

administrator   ~0010029

@fearx135 I believe that this is not the same issue. We do already have 5.1.3 in Kali. And i checked that the patch that you pointed is part of the 5.1.3 release that is already packaged.

Issue History

Date Modified Username Field Change
2018-09-09 04:02 tjb New Issue
2018-10-23 01:48 tjb Note Added: 0009827
2018-10-23 01:50 tjb Note Added: 0009828
2018-11-26 01:44 tjb Note Added: 0009994
2018-11-27 23:58 fearx135 Note Added: 0010027
2018-11-28 07:50 rhertzog Note Added: 0010029