View Issue Details

IDProjectCategoryView StatusLast Update
0005029Kali Linux[All Projects] Tool Upgradepublic2019-04-08 12:39
Reporterfaraday-devAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005029: Faraday v3.1 improvements
DescriptionHi,

We have been testing the kali rolling and we found that faraday is using a random password and uses always the same secret key (which is a random string).

We made some changes in the latest version (v3.1) to improve the installation in kali. The command initdb has a new parameter called --choose-password that will ask the user for the admin password.

We think that the faraday script should check if the .faraday directory exists and if it does not exists it will call python manage.py initdb --choose-password and it will set the admin password and generate a random secret key.

Next time when the user executes faraday it will call the gtk client since the .faraday directory exists.

Let me know if you need some help with the bash script we can try to create one for kali.

Thanks!

Activities

faraday-dev

2018-10-12 22:18

reporter   ~0009813

We are happy to announce that next week we are releasing faraday v3.2.
In this version we removed restkit library.

sbrun

2019-04-08 12:39

manager   ~0010488

fixed in version 3.6.0-0kali3

Issue History

Date Modified Username Field Change
2018-10-04 15:59 faraday-dev New Issue
2018-10-04 15:59 faraday-dev Status new => assigned
2018-10-04 15:59 faraday-dev Assigned To => sbrun
2018-10-12 22:18 faraday-dev Note Added: 0009813
2019-04-08 12:39 sbrun Status assigned => resolved
2019-04-08 12:39 sbrun Resolution open => fixed
2019-04-08 12:39 sbrun Note Added: 0010488