View Issue Details

IDProjectCategoryView StatusLast Update
0005031Kali Linux[All Projects] General Bugpublic2018-10-05 19:29
ReporterjplstonerAssigned Tosteev 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.3 
Target VersionFixed in Version2018.4 
Summary0005031: 2018.4 Missing nexutil, cannot switch to monitor mode.
DescriptionI installed Kali Linux per your website using the RPI 2/3 image. Once installed, I ran apt-get update, apt-get upgrade, rebooted, ran apt -y full-upgrade. But it install 2018.4 which I see is not released yet. I am using a Raspberry Pi 3 Model B with the onboard wifi adapter. I was able to put into monitor mode before. But this is a complete fresh install. This time when I run airmon-ng start wlan0 (which I have confirmed is my wifi adapter) it states on the screen that Missing nexutil, Cannot switch to monitor mode.

Activities

steev

2018-10-05 18:08

developer   ~0009782

Last edited: 2018-10-05 18:10

View 2 revisions

This is due to an oversight on my part in the scripts where I had installed firmware-broadcom in the 2018.3 images; it'll be fixed in our next release.

For now, to fix the issue, what you'll need to do is:

apt purge firmware-brcm80211
cd /lib/firmware/brcm
cp brcmfmac43430-sdio.nexmon.bin brcmfmac43430-sdio.bin
cp brcmfmac43455-sdio.nexmon.bin brcmfmac43455-sdio.bin

then either reboot, or modprobe -r brcmfmac; modprobe brcmfmac

What happened is that a newer version of the broadcom firmware came in, and the nexmon firmware was overwritten.

steev

2018-10-05 18:15

developer   ~0009783

Actually, that's a separate issue - I *believe* the issue you're running into is because nexmon changed the way that monitor mode is started - you can run monstart and monstop to start and stop monitor mode. I'm not 100% but I believe that this was fixed in aircrack-ng 1.4, which isn't in Kali yet.

Mister_X

2018-10-05 18:28

reporter   ~0009784

It was fixed in Aircrack-ng 1.4.

If you'd like more details, check out https://github.com/aircrack-ng/aircrack-ng/issues/1929 which references the commit that fixed the issue: https://github.com/aircrack-ng/aircrack-ng/commit/db004e7f88837b430f497b3331bdf304696cfe2b

As mentioned, you can use monstop and monstart commands until 1.4 hits the repositories.

jplstoner

2018-10-05 18:31

reporter   ~0009785

Thank you all for the updates, I actually just began trying what threeway suggested. I did try monstart before hand but i got an error saying "Bring up monitor mode interface wlan0mon, command failed: Operation not supported (-95), wlan0mon: ERROR while getting interface flags: No Such Device.

jplstoner

2018-10-05 18:43

reporter   ~0009786

Ok, So I took both of your ideas and they worked, sorta. After following the directions from threesome, I still got the same error message about nexutil. So I tried monstart again and it work, I confirmed by typing airodum-ng wlan0mon and it is not monitoring surrounding wifi networks. Thank you all for your support and such awesome tools ...

steev

2018-10-05 19:11

developer   ~0009789

Just to be clear, because I think there's a typo in your comment - it *is now* or *is not* monitoring surrounding wifi networks?

jplstoner

2018-10-05 19:12

reporter   ~0009790

It "is now" monitoring surrounding wifi networks.Nice catch, my apologies...

steev

2018-10-05 19:29

developer   ~0009791

The issue will be fixed by both aircrack-ng 1.4 and the change already made to the rpi build scripts.

Issue History

Date Modified Username Field Change
2018-10-05 15:59 jplstoner New Issue
2018-10-05 18:08 steev Note Added: 0009782
2018-10-05 18:10 steev Note Edited: 0009782 View Revisions
2018-10-05 18:15 steev Note Added: 0009783
2018-10-05 18:28 Mister_X Note Added: 0009784
2018-10-05 18:31 jplstoner Note Added: 0009785
2018-10-05 18:43 jplstoner Note Added: 0009786
2018-10-05 19:11 steev Note Added: 0009789
2018-10-05 19:12 jplstoner Note Added: 0009790
2018-10-05 19:29 steev Assigned To => steev
2018-10-05 19:29 steev Status new => resolved
2018-10-05 19:29 steev Resolution open => fixed
2018-10-05 19:29 steev Fixed in Version => 2018.4
2018-10-05 19:29 steev Note Added: 0009791