View Issue Details

IDProjectCategoryView StatusLast Update
0005061Kali Linux[All Projects] General Bugpublic2018-11-07 20:38
ReporterTinLethaxAssigned Tosteev 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.1 
Target VersionFixed in Version2019.1 
Summary0005061: xfsettingsd(in package of xfce4-setting) caused high cpu load every 2 or 3 sec.
DescriptionAfter apt-get upgrade 2-3 weeks ago .xfsettingsd start to use high load every 2 or 3 second .its cause other xfce4's program to use high load too .I have the video recorded using my phone to show the "top" command telling me about cpu usage of program imdividually .link https://youtu.be/J_GdGdvsal4

PC : Netbook
Brand : Samsung
CPU :Intel Atom N550 @1.5 GHz
Architecture:x86_64
Ram:Hynix 2gb 1333 DDR3
HDD:Seagate 500gb

Kali
Cat /proc/version gave me this
Linux version 4.18.0-kali2-amd64 (devel@kali.org) (gcc version 7.3.0 (Debian 7.3.0-29)) 0000001 SMP Debian 4.18.10-2kali1 (2018-10-09)
Release : kali-rolling
Codename : kali-rolling
xfce4-settings version(downgraded) :4.12.0
-0ubuntu1 (installes through .deb package)
xfce4 version : 4.12.4
xfwm4 version : 4.12.5-1

Activities

TinLethax

TinLethax

2018-10-31 00:38

reporter   ~0009880

I chose wrong release .It's the 2018.4 not 2018.1 .
kaliuser

kaliuser

2018-10-31 14:11

reporter   ~0009882

In VirtualBox 5.2.20 when booting from ISO in live mode, there is the same bug!
steev

steev

2018-10-31 23:16

developer   ~0009884

This also occurs on arm64.

A workaround exists by killing xfsettingsd and then relaunching it, but it comes back after a logout/login.

Another workaround is downgrading libfontconfig1 and fontconfig to 2.30, however it's not a good workaround as 2.30 crashes on empty font folders.
TinLethax

TinLethax

2018-10-31 23:26

reporter   ~0009885

Hey . How can it down grade ? Use dpkg remove --force-depends and install fontconfig.deb ?
steev

steev

2018-10-31 23:35

developer   ~0009886

You would need to download the 2.13.0 version from Debian's servers. You can see what I do in the raspberrypi3 64bit image at

https://github.com/offensive-security/kali-arm-build-scripts/blob/master/rpi3-64.sh#L188-L189 for the wgets (obviously you'd want to choose the architecture you're running on!)
and then see
https://github.com/offensive-security/kali-arm-build-scripts/blob/master/rpi3-64.sh#L232-L234 for how I install them (just apt install with the fixed path on the file system)
TinLethax

TinLethax

2018-10-31 23:54

reporter   ~0009888

Oh .thanks
steev

steev

2018-11-06 20:27

developer   ~0009907

Looks like Debian have fixed the issue in 2.13.1-2 upstream, so as soon as we pull that in, you shouldn't see this issue anymore (though you'll likely have to reboot/restart your login manager for the new fontconfig)

Upstream debian bug is Bug# 909818
steev

steev

2018-11-07 20:38

developer   ~0009915

Looks like the updated packages are on the mirrors, thanks for the report, please be sure to apt-get update && apt-get dist-upgrade to pull in the fixed version of fontconfig.

Issue History

Date Modified Username Field Change
2018-10-31 00:34 TinLethax New Issue
2018-10-31 00:38 TinLethax Note Added: 0009880
2018-10-31 14:11 kaliuser Note Added: 0009882
2018-10-31 23:16 steev Note Added: 0009884
2018-10-31 23:26 TinLethax Note Added: 0009885
2018-10-31 23:35 steev Note Added: 0009886
2018-10-31 23:54 TinLethax Note Added: 0009888
2018-11-06 20:27 steev Note Added: 0009907
2018-11-07 20:38 steev Assigned To => steev
2018-11-07 20:38 steev Status new => resolved
2018-11-07 20:38 steev Resolution open => fixed
2018-11-07 20:38 steev Fixed in Version => 2019.1
2018-11-07 20:38 steev Note Added: 0009915
2018-11-08 10:36 D tk Issue cloned: 0005085