View Issue Details

IDProjectCategoryView StatusLast Update
0005074Kali Linux[All Projects] General Bugpublic2018-11-16 08:08
ReporterDante16 Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005074: Kali login loop
DescriptionHello,

I updated and upgraded Kali a few hours ago and then did a reboot, once booted up I can`t login to my normal user but I can login with root user, when using my normal user the login screen will loop back to its original format.

I have tried CTRL + ALT + F2 and then :

1. a. dpkg --configure -a
     b. sudo apt-get update
     c. sudo apt-get upgrade
     d. sudo reboot

2. a. -sudo apt-get update
    b. -sudo apt-get upgrade
    c -dpkg --configure -a
    d -sudo apt-get install cinnamon-control-center-data
    e -gdm3 --version
    f -apt-get --reinstall install gdm3
    g -apt-get --reinstall install gnome
    h -apt-get --reinstall install gnome-shell
    i -dpkg-reconfigure gdm3
    j-reboot

3. a. apt-get install x-window-system
     b. startx

None of these worked, still only root user access. Any other possible fixes ?

Activities

rhertzog

2018-11-05 10:07

administrator   ~0009895

You might want to try to login with a different "session", cilck on the small "cog/wheel" icon after having entered your username. It might be that the cinnamon session or whatever you are using by default is broken. In that case, you should look into logs to find out why the session is exiting immediately.

Dante16

2018-11-05 12:04

reporter   ~0009896

I have cinnamon, gnome and gnome clasic.
Sorry, forgot to mention that tried them also and same on all 3. I don't know if it actually did login or the loop might just be too fast for me to see. User, password then user again after enter at password ...

rhertzog

2018-11-05 14:25

administrator   ~0009897

If the password is wrong, the screen shakes and you have a red error message. So the session probably tries to start, but fails for some reasons. Thus you have to look into your logs to find out the reason of the failure... have a look at the output of "journalctl", etc.

Dante16

2018-11-05 20:49

reporter   ~0009899

As I said, user, password and user again, wrong password does not prompt you to enter user again but it asks you to reenter the password again, it's not that anyway.

Had a look in journalclt but it's A LOT of info, about 1000 lines per second � and not sure at the specific time the error accrued so don't know what to sort by ...

Anyway, do you have any other fix for this issue ?

rhertzog

2018-11-06 08:00

administrator   ~0009900

If you are not able to find out the messages that are added the logs at the time you typed "enter" in your login screen, then we can't provide a fix since we don't know what's the problem. Nobody else reported such a problem so far.

It's not too hard to open a root shell with "journalctl -f | less", then go back to your login screen, do the login test, go back to the shell and look at the new lines that appeared... possibly take a screenshot of the suspicious messages.

Dante16

2018-11-06 09:00

reporter   ~0009901

Managed to delete the user and add a new one with same name and now works.

Can I still find the error report even if the user has been deleted ? I want to post it so someone can have a look and possibly provide a fix if the issue will pop up to someone else in the future.

If possible I'll have a look later when I get home.
Thanks

Dante16

2018-11-16 03:17

reporter   ~0009957

Couldn't find the issue using "journalctl -f | less" but fixed anyway by a new user creation.

Thanks for the help :-)

Topic can be marked as solved.

Issue History

Date Modified Username Field Change
2018-11-04 17:27 Dante16 New Issue
2018-11-05 10:07 rhertzog Status new => feedback
2018-11-05 10:07 rhertzog Note Added: 0009895
2018-11-05 12:04 Dante16 Note Added: 0009896
2018-11-05 12:04 Dante16 Status feedback => new
2018-11-05 14:25 rhertzog Note Added: 0009897
2018-11-05 20:49 Dante16 Note Added: 0009899
2018-11-06 08:00 rhertzog Note Added: 0009900
2018-11-06 09:00 Dante16 Note Added: 0009901
2018-11-16 03:17 Dante16 Note Added: 0009957
2018-11-16 08:08 sbrun Assigned To => sbrun
2018-11-16 08:08 sbrun Status new => resolved
2018-11-16 08:08 sbrun Resolution open => fixed