View Issue Details

IDProjectCategoryView StatusLast Update
0005078Kali Linux[All Projects] Kali Package Bugpublic2018-11-08 13:53
Reporterpkreuzt Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005078: rtlsdr-scanner fails with error
Descriptionrtlsdr-scanner depends on python-matplotlib, whose API has changed and now axisbg property is deprecated:

This causes rtlsdr-scanner to fail when launched, see appended traceback.



2018-11-06 17:51


rtlsdr-scanner-traceback.txt (1,489 bytes)
Traceback (most recent call last):
  File "./", line 129, in <module>
    frame = FrameMain(APP_NAME)
  File "/usr/share/rtlsdr-scanner/", line 177, in __init__
  File "/usr/share/rtlsdr-scanner/", line 201, in __create_toolbars
  File "/usr/share/rtlsdr-scanner/", line 114, in __init__
  File "/usr/share/rtlsdr-scanner/", line 297, in create_plot
    self.plot = Plotter(self.notify, self.figure, self.settings)
  File "/usr/share/rtlsdr-scanner/", line 67, in __init__
  File "/usr/share/rtlsdr-scanner/", line 76, in __setup_plot
  File "/usr/lib/python2.7/dist-packages/matplotlib/", line 1239, in add_subplot
    a = subplot_class_factory(projection_class)(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/matplotlib/axes/", line 77, in __init__
    self._axes_class.__init__(self, fig, self.figbox, **kwargs)
  File "/usr/lib/python2.7/dist-packages/matplotlib/axes/", line 539, in __init__
  File "/usr/lib/python2.7/dist-packages/matplotlib/", line 888, in update
    for k, v in props.items()]
  File "/usr/lib/python2.7/dist-packages/matplotlib/", line 881, in _update_property
    raise AttributeError('Unknown property %s' % k)
AttributeError: Unknown property axisbg


2018-11-06 21:23

developer   ~0009908

Have you tried the upstream repository to see if it still occurs there?

We should probably version bump this to the latest release, regardless.


2018-11-06 22:32

reporter   ~0009909

I just tried version 1.3.2 from upstream and at least it runs, probably the bug is version dependant.


2018-11-08 13:53

manager   ~0009931

new version 1.3.2-0kali1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2018-11-06 17:51 pkreuzt New Issue
2018-11-06 17:51 pkreuzt File Added: rtlsdr-scanner-traceback.txt
2018-11-06 21:23 steev Note Added: 0009908
2018-11-06 22:32 pkreuzt Note Added: 0009909
2018-11-07 13:29 sbrun Assigned To => sbrun
2018-11-07 13:29 sbrun Status new => assigned
2018-11-08 13:53 sbrun Status assigned => resolved
2018-11-08 13:53 sbrun Resolution open => fixed
2018-11-08 13:53 sbrun Note Added: 0009931