View Issue Details

IDProjectCategoryView StatusLast Update
0005111Kali Linux[All Projects] General Bugpublic2019-02-07 13:10
ReporterwakenAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005111: Desktop shortcuts stop working in Kali Linux XFCE after update
DescriptionWhen user tries to launch application using desktop shortcut pop-up with error appears.

Example of the error with firefox-esr shortcut:
Header: Launch Error
Title: Failed to run "firefox-esr.desktop"
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Steps to reproduce:
1. Create the shortcut on the Desktop for any application
2. Launch the shortcut

The error appears. Application doesn't not run.

Env. details:
# uname -a
Linux kali 4.18.0-kali2-amd64 0000001 SMP Debian 4.18.10-2kali1 (2018-10-09) x86_64 GNU/Linux



2018-11-21 12:53


Capture.PNG (12,250 bytes)
Capture.PNG (12,250 bytes)


2018-11-27 16:22

reporter   ~0010025

Hi, I have the same issue.

I use Kali with xfce4 desktop environment. And before update system work good.
After update , when I try to open some files from desktop i have some errors in log - journalctl -b i see:

Nov 27 19:02:31 kalin dbus-daemon[812]: [session uid=0 pid=812] Activating via systemd: service name='org.xfce.FileManager' unit='thunar.service' requested by ':1.17
Nov 27 19:02:31 kalin systemd[781]: Starting Thunar file manager...
Nov 27 19:02:31 kalin systemd[781]: Started Thunar file manager.
Nov 27 19:04:31 kalin dbus-daemon[812]: [session uid=0 pid=812] Failed to activate service 'org.xfce.FileManager': timed out (service_start_timeout=120000ms)

I already try to clear .cache folder
Reinstall Thunar, xfce4.
Change lightdm to gdm3
Problem not solved.

I try clear install from kali-linux-xfce-2018-W47-amd64.iso - and have this issue after install.


2018-12-03 09:00

reporter   ~0010067

The same issue. Exists only under root user!
I also can't create files or folders on the desktop. Paste files or folders to desktop.
No errors, just no reaction.
I guess that problem in dbus. Maybe downgrade can help, but I don't know how to do it.


2019-01-18 09:16

reporter   ~0010225

Please, share workaround if you have.

Issue History

Date Modified Username Field Change
2018-11-21 12:53 waken New Issue
2018-11-21 12:53 waken File Added: Capture.PNG
2018-11-27 16:22 artv Note Added: 0010025
2018-12-03 09:00 Serg Note Added: 0010067
2019-01-18 09:16 waken Note Added: 0010225