View Issue Details

IDProjectCategoryView StatusLast Update
0005159Kali Linux[All Projects] Kali Package Bugpublic2019-01-10 08:47
ReporterMister_XAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005159: airgraph-ng fails to find file when using relative path
Descriptionairgraph-ng executable is a shell script changing directory then calling airgraph-ng: `cd /usr/share/airgraph-ng && python airgraph-ng "$@"`

If the paths given aren't absolute, it will likely fail due to the change in directories (the CSV file isn't present in /usr/share/airgraph-ng).

Steps To Reproducecd ~
airmon-ng check kill
airmon-ng start wlan0
airodump-ng -i wlan0mon -w dump --output-format csv
airgraph-ng -i dump-01.csv -o dump.png -g CAPR
Additional InformationChanging `cd /usr/share/airgraph-ng && python airgraph-ng "$@"` to `python /usr/share/airgraph-ng/airgraph-ng "$@"` in the /usr/bin/airgraph-ng shell script solves the issue.

Activities

sbrun

2019-01-10 08:47

manager   ~0010186

fixed in version 1:1.5.2-3

Issue History

Date Modified Username Field Change
2018-12-14 22:38 Mister_X New Issue
2018-12-19 09:54 sbrun Assigned To => sbrun
2018-12-19 09:54 sbrun Status new => assigned
2019-01-10 08:47 sbrun Status assigned => resolved
2019-01-10 08:47 sbrun Resolution open => fixed
2019-01-10 08:47 sbrun Note Added: 0010186