View Issue Details

IDProjectCategoryView StatusLast Update
0005190Kali Linux[All Projects] General Bugpublic2019-01-05 00:23
ReporterprivateAssigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005190: libgnutls30-3.6.5-2 breaks http transport
Descriptionlibgnutls30-3.6.5-2 after last kali upgrade results to the following error:
relocation error: /usr/lib/x86_64-linux-gnu/libgnutls.so.30:symbol nettle_rsa_sec_decrypt version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference

The bug is of major importance as it seems to break all http transport requests which use the gnutls30 library and makes the system totally unusable. The only solution I got to was to downgrade to the previous package version of libgnutls (libgnutls30-3.5.19) and installing it manually using dpkg. However, if you try to upgrade anything in the current state it would report libgnutls30 is incorrect version:
# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 apt : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 glib-networking : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 ldap-utils : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 libavformat58 : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 libgnutls-dane0 : Depends: libgnutls30 (= 3.6.5-2) but 3.5.19-1 is installed
 libgnutls-openssl27 : Depends: libgnutls30 (= 3.6.5-2) but 3.5.19-1 is installed
 libgnutls30 : Breaks: libgnutls30:i386 (!= 3.5.19-1) but 3.6.5-2 is installed
 libgnutls30:i386 : Breaks: libgnutls30 (!= 3.6.5-2) but 3.5.19-1 is installed
 libgnutlsxx28 : Depends: libgnutls30 (= 3.6.5-2) but 3.5.19-1 is installed
 libldap-2.4-2 : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 libvte-2.91-0 : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 systemd : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 vino : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 vlc-plugin-base : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
 wget : Depends: libgnutls30 (>= 3.6.5) but 3.5.19-1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

In order for apt to let you upgrade anything you have to upgrade libgnutls30 which results in the above issue and it's a closed circle. There's a similar issue in fedora reported here:
https://forums.fedoraforum.org/showthread.php?320208-F29-No-network-after-kernel-upgrade&p=1816934#post1816934

Can anyone confirm this can be reproduced and will be packed properly?
Steps To Reproduceupgrade to the latest kali libgnutls30 package (3.6.5-2) either using apt-get upgrade or manually using apt-get install libgnutls
Additional Information# lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2019.1
Codename: n/a

# dpkg -l | grep libgnutls
ii libgnutls-dane0:amd64 3.6.5-2 amd64 GNU TLS library - DANE security support
ii libgnutls-openssl27:amd64 3.6.5-2 amd64 GNU TLS library - OpenSSL wrapper
iU libgnutls30:amd64 3.5.19-1 amd64 GNU TLS library - main runtime library
-->> PROBLEMATIC PACKAGE, NETWORK LOCKS OUT OF ITSELF AFTER UPGRADING TO 3.6.5-2

iF libgnutls30:i386 3.6.5-2 i386 GNU TLS library - main runtime library
ii libgnutlsxx28:amd64 3.6.5-2 amd64 GNU TLS library - C++ runtime library

Activities

kburke15

2019-01-04 20:57

reporter   ~0010162

I think I am having the same problem as you. Is it saying that it can't find your wifi adapter too? I know it has something to do with the update because the wifi adapter worked perfectly before the update, and now after the update, it doesn't work at all. This is definitely a serious problem that I hope the developers get to.

kburke15

2019-01-04 21:10

reporter   ~0010163

Never mind, I am not having the same issue you are having. It seems when they coded the update for the operating system, it gave everyone different problems.

private

2019-01-05 00:23

reporter   ~0010164

The issue was resolved by deleting all instances of libhogweed.so.4, then downgrading to the previous version of libgnutls30 (so that I can get http transport requests to work), and then use apt-get --fix-broken install to install the new libgnutls30 package and its proper dependencies matching the libhogweed4 and libnettle6 package versions. It seems that the issue was caused due to libhogweed.so.4 being in all possible lib paths and the new package not overriding all the files, thus some of them which are still in the PATH environment variable were used by libgnutls binaries which seem to lack the nettle_rsa_sec_decrypt function.

Solution:
1) locate libhogweed.so.4
2) rm {/usr/lib/i386-linux-gnu/libhogweed.so.4,/usr/lib/i386-linux-gnu/libhogweed.so.4.5,/usr/lib/x86_64-linux-gnu/libhogweed.so.4,/usr/lib/x86_64-linux-gnu/libhogweed.so.4.5

3) dpkg -i libgnutls30_3.5.19-1_amd64.deb libgnutls30_3.5.19-1_i386.deb
(or dpkg -i libgnutls30_3.5.19-1+b1_amd64.deb libgnutls30_3.5.19-1+b1_i386.deb)
(download the necessary package from http://http.kali.org/pool/main/g/gnutls28/)
4) apt-get --fix-broken install
5) You may need to tweak around with dpkg and the packages involved: libnettle6, libhogweed4, libgnutls30), if something does not work downgrade to the previous version some of them to get the network up.

Issue History

Date Modified Username Field Change
2019-01-04 15:22 private New Issue
2019-01-04 20:57 kburke15 Note Added: 0010162
2019-01-04 21:10 kburke15 Note Added: 0010163
2019-01-05 00:23 private Note Added: 0010164