View Issue Details

IDProjectCategoryView StatusLast Update
0005199Kali Linux[All Projects] Tool Upgradepublic2019-01-23 05:32
ReporterRoseDeSableAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005199: squid: no negotiation to upstream proxy after dist-upgrade of 04. January 2019
DescriptionHallo Leute,
 since two years I'm locally using the proxy 'squid' under my kali. The proxy authenticates itself about kerberos on the upstream proxy of my enterprise. Here you see the two necessary statements in squid.conf:
auth_param negotiate program /usr/lib/squid3/negotiate_kerberos_auth -d -s HTTP/thePrincipalofthe ProxyofMyEnterprise
cache_peer myproxy parent 3128 0 no-query login=NEGOTIATE:myAccount
I'm updating my kali two times at week, if patches are available. So also last week. After restarting of the system I never could go into the internet. Here is the result of my analysing:
Squid makes a plaintext authentication instead a negotiation. I see this in the packet trace. The squid sends the plaintext credential 'NEGOTIATE:myAccount' to the upstream proxy. It seems to be, as if squid doesn't understand the keywort NEGOTIATE and use it as a username !

Who can help ?

Activities

RoseDeSable

2019-01-22 08:19

reporter   ~0010229

Hello,
 I did no other changes as installing the newest distribution upgrade of Kali this morning: the problem now is solved.

Auf Wiedersehen

rhertzog

2019-01-23 05:32

administrator   ~0010231

Closing ticket since issue is resolved according to the bug reporter.

Issue History

Date Modified Username Field Change
2019-01-07 13:12 RoseDeSable New Issue
2019-01-07 13:12 RoseDeSable Status new => assigned
2019-01-07 13:12 RoseDeSable Assigned To => sbrun
2019-01-22 08:19 RoseDeSable Note Added: 0010229
2019-01-23 05:32 rhertzog Status assigned => resolved
2019-01-23 05:32 rhertzog Resolution open => no change required
2019-01-23 05:32 rhertzog Note Added: 0010231