View Issue Details

IDProjectCategoryView StatusLast Update
0005227Kali Linux[All Projects] General Bugpublic2019-01-30 10:22
ReportergenuixAssigned Torhertzog 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005227: apt-upgrade fail - get 404
Descriptionwhen trying to upgrade packages get 404 error from kali linux server

Steps To Reproduceapt update && apt upgrade
Additional Informationsudo apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  appstream apt-config-icons bash bettercap clang-6.0 gir1.2-goa-1.0 gnome-online-accounts icu-devtools kactivitymanagerd ksshaskpass kwayland-integration
  libappstream4 libclang-common-6.0-dev libclang1-6.0 libgoa-1.0-0b libgoa-1.0-common libgoa-backend-1.0-1 libicu-dev libicu63 libllvm6.0 libnet-snmp-perl
  libpam-kwallet-common libpam-kwallet5 librdf0 llvm-6.0 llvm-6.0-dev llvm-6.0-runtime pkg-config plasma-nm polkit-kde-agent-1 python-bcrypt python3-bcrypt
  ruby-dataobjects-mysql
33 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 89.1 MB of archives.
After this operation, 82.9 kB disk space will be freed.
Do you want to continue? [Y/n]
Err:1 http://http.kali.org/kali kali-rolling/main amd64 bash amd64 5.0-2
  404 Not Found [IP: 192.99.200.113 80]
Err:2 http://http.kali.org/kali kali-rolling/main amd64 libappstream4 amd64 0.12.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:3 http://http.kali.org/kali kali-rolling/main amd64 appstream amd64 0.12.5-1
  404 Not Found [IP: 192.99.200.113 80]
Ign:4 http://http.kali.org/kali kali-rolling/main amd64 apt-config-icons all 0.12.5-1
Err:5 http://http.kali.org/kali kali-rolling/main amd64 bettercap amd64 2.13-0kali1
  404 Not Found [IP: 192.99.200.113 80]
Err:6 http://http.kali.org/kali kali-rolling/main amd64 clang-6.0 amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:7 http://http.kali.org/kali kali-rolling/main amd64 libclang-common-6.0-dev amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:8 http://http.kali.org/kali kali-rolling/main amd64 llvm-6.0-dev amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:9 http://http.kali.org/kali kali-rolling/main amd64 llvm-6.0 amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:10 http://http.kali.org/kali kali-rolling/main amd64 llvm-6.0-runtime amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:11 http://http.kali.org/kali kali-rolling/main amd64 libllvm6.0 amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Err:12 http://http.kali.org/kali kali-rolling/main amd64 libclang1-6.0 amd64 1:6.0.1-10
  404 Not Found [IP: 192.99.200.113 80]
Ign:13 http://http.kali.org/kali kali-rolling/main amd64 libgoa-1.0-common all 3.30.1-1
Err:14 http://http.kali.org/kali kali-rolling/main amd64 gnome-online-accounts amd64 3.30.1-1
  404 Not Found [IP: 192.99.200.113 80]
Err:15 http://http.kali.org/kali kali-rolling/main amd64 libgoa-backend-1.0-1 amd64 3.30.1-1
  404 Not Found [IP: 192.99.200.113 80]
Err:16 http://http.kali.org/kali kali-rolling/main amd64 libgoa-1.0-0b amd64 3.30.1-1
  404 Not Found [IP: 192.99.200.113 80]
Err:17 http://http.kali.org/kali kali-rolling/main amd64 gir1.2-goa-1.0 amd64 3.30.1-1
  404 Not Found [IP: 192.99.200.113 80]
Err:18 http://http.kali.org/kali kali-rolling/main amd64 libicu-dev amd64 63.1-6
  404 Not Found [IP: 192.99.200.113 80]
Err:19 http://http.kali.org/kali kali-rolling/main amd64 icu-devtools amd64 63.1-6
  404 Not Found [IP: 192.99.200.113 80]
Err:20 http://http.kali.org/kali kali-rolling/main amd64 libicu63 amd64 63.1-6
  404 Not Found [IP: 192.99.200.113 80]
Err:21 http://http.kali.org/kali kali-rolling/main amd64 kactivitymanagerd amd64 5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:22 http://http.kali.org/kali kali-rolling/main amd64 ksshaskpass amd64 4:5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:23 http://http.kali.org/kali kali-rolling/main amd64 kwayland-integration amd64 5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Ign:24 http://http.kali.org/kali kali-rolling/main amd64 libnet-snmp-perl all 6.0.1-5
Err:25 http://http.kali.org/kali kali-rolling/main amd64 libpam-kwallet5 amd64 5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Ign:26 http://http.kali.org/kali kali-rolling/main amd64 libpam-kwallet-common all 5.14.5-1
Err:27 http://http.kali.org/kali kali-rolling/main amd64 librdf0 amd64 1.0.17-1.1+b1
  404 Not Found [IP: 192.99.200.113 80]
Err:28 http://http.kali.org/kali kali-rolling/main amd64 pkg-config amd64 0.29-6
  404 Not Found [IP: 192.99.200.113 80]
Err:29 http://http.kali.org/kali kali-rolling/main amd64 plasma-nm amd64 4:5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:30 http://http.kali.org/kali kali-rolling/main amd64 polkit-kde-agent-1 amd64 4:5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:31 http://http.kali.org/kali kali-rolling/main amd64 python-bcrypt amd64 3.1.6-1
  404 Not Found [IP: 192.99.200.113 80]
Err:32 http://http.kali.org/kali kali-rolling/main amd64 python3-bcrypt amd64 3.1.6-1
  404 Not Found [IP: 192.99.200.113 80]
Err:33 http://http.kali.org/kali kali-rolling/main amd64 ruby-dataobjects-mysql amd64 0.10.16-2+b3
  404 Not Found [IP: 192.99.200.113 80]
Err:4 http://http.kali.org/kali kali-rolling/main amd64 apt-config-icons all 0.12.5-1
  404 Not Found [IP: 192.99.200.113 80]
Err:13 http://http.kali.org/kali kali-rolling/main amd64 libgoa-1.0-common all 3.30.1-1
  404 Not Found [IP: 192.99.200.113 80]
Err:24 http://http.kali.org/kali kali-rolling/main amd64 libnet-snmp-perl all 6.0.1-5
  404 Not Found [IP: 192.99.200.113 80]
Err:26 http://http.kali.org/kali kali-rolling/main amd64 libpam-kwallet-common all 5.14.5-1
  404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/b/bash/bash_5.0-2_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/a/appstream/libappstream4_0.12.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/a/appstream/appstream_0.12.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/a/appstream/apt-config-icons_0.12.5-1_all.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/b/bettercap/bettercap_2.13-0kali1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/clang-6.0_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/libclang-common-6.0-dev_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/llvm-6.0-dev_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/llvm-6.0_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/llvm-6.0-runtime_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/libllvm6.0_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/l/llvm-toolchain-6.0/libclang1-6.0_6.0.1-10_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnome-online-accounts/libgoa-1.0-common_3.30.1-1_all.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnome-online-accounts/gnome-online-accounts_3.30.1-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnome-online-accounts/libgoa-backend-1.0-1_3.30.1-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnome-online-accounts/libgoa-1.0-0b_3.30.1-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnome-online-accounts/gir1.2-goa-1.0_3.30.1-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/i/icu/libicu-dev_63.1-6_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/i/icu/icu-devtools_63.1-6_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/i/icu/libicu63_63.1-6_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/k/kactivitymanagerd/kactivitymanagerd_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/k/ksshaskpass/ksshaskpass_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/k/kwayland-integration/kwayland-integration_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/libn/libnet-snmp-perl/libnet-snmp-perl_6.0.1-5_all.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/k/kwallet-pam/libpam-kwallet5_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/k/kwallet-pam/libpam-kwallet-common_5.14.5-1_all.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/r/redland/librdf0_1.0.17-1.1+b1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/p/pkg-config/pkg-config_0.29-6_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/p/plasma-nm/plasma-nm_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/p/polkit-kde-agent-1/polkit-kde-agent-1_5.14.5-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/p/python-bcrypt/python-bcrypt_3.1.6-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/p/python-bcrypt/python3-bcrypt_3.1.6-1_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/r/ruby-dataobjects-mysql/ruby-dataobjects-mysql_0.10.16-2+b3_amd64.deb 404 Not Found [IP: 192.99.200.113 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Activities

rhertzog

2019-01-29 16:25

administrator   ~0010242

We need the output of "apt update" to be able to diagnose anything. Right now it looks like you forgot this step, or maybe have been redirected to a mirror which is out of date and has a problem, but then we need to know which one and we would see this in the output of "apt update".

genuix

2019-01-30 09:28

reporter   ~0010243

here the apt update result.

but you can close the ticket as this morning it has worked correctly

Many thanks for support and kind regards

Hit:1 http://linux.teamviewer.com/deb stable InRelease
Hit:2 https://repo.skype.com/deb stable InRelease
Get:3 http://cdn-fastly.deb.debian.org/debian jessie-backports InRelease [166 kB]
Hit:5 https://download.sublimetext.com apt/stable/ InRelease
Get:4 http://kali.download/kali kali-rolling InRelease [30.5 kB]
Get:6 http://kali.download/kali kali-rolling/main amd64 Packages [17.0 MB]
Get:7 http://kali.download/kali kali-rolling/main i386 Packages [16.9 MB]
Get:8 http://kali.download/kali kali-rolling/contrib amd64 Packages [98.3 kB]
Fetched 34.2 MB in 8s (4,427 kB/s)
Reading package lists... Done

Issue History

Date Modified Username Field Change
2019-01-29 15:49 genuix New Issue
2019-01-29 15:49 genuix Status new => assigned
2019-01-29 15:49 genuix Assigned To => sbrun
2019-01-29 16:25 rhertzog Note Added: 0010242
2019-01-29 16:26 rhertzog Assigned To sbrun => rhertzog
2019-01-29 16:26 rhertzog Status assigned => feedback
2019-01-29 16:27 rhertzog Category Tool Upgrade => General Bug
2019-01-30 09:28 genuix Note Added: 0010243
2019-01-30 09:28 genuix Status feedback => assigned
2019-01-30 10:22 sbrun Status assigned => resolved
2019-01-30 10:22 sbrun Resolution open => fixed