View Issue Details

IDProjectCategoryView StatusLast Update
0005237Kali Linux[All Projects] General Bugpublic2019-12-12 08:08
Reporterrhertzog Assigned Torhertzog  
PriorityhighSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2018.4 
Target Version2019.2Fixed in Version2019.4 
Summary0005237: Enable Mediatek MT76* modules for wireless adapters
DescriptionWe are currently lacking support for some Mediatek wireless adapters. We need to ensure it gets enabled in Debian:
In the kernel: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918331
In the firmware package too: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=919452

Reported by @steev.

Activities

rhertzog

2019-02-05 11:33

administrator   ~0010258

Reminder to myself when I get around to prepare a merge request against https://salsa.debian.org/kernel-team/linux :
- instructions to build from git: https://kernel-team.pages.debian.net/kernel-handbook/ch-common-tasks.html#s-common-official-vcs
- should do a merge a request against the "sid" branch (ex: https://salsa.debian.org/kernel-team/linux/merge_requests/114)

(or as a hint to @steev if he wants to give it a try ;-))

rhertzog

2019-03-29 15:16

administrator   ~0010459

The modules are now available with the latest linux (>= 4.19.20). The firmware package still needs to be updated. I submitted a merge request to help speed this up: https://salsa.debian.org/kernel-team/firmware-nonfree/merge_requests/7

rhertzog

2019-06-24 12:56

administrator   ~0010729

The firmware package has been updated but a release critical bug kept the package out of testing ever since its upload. @steev should I try to get this solved or can we wait until someone fixes this release critical bug?

rhertzog

2019-07-08 14:40

administrator   ~0010770

FTR, the problematic bug is this one: https://bugs.debian.org/928631

rhertzog

2019-12-12 08:08

administrator   ~0011659

The updated firmware and drivers have been available in testing and Kali for a while now.

Issue History

Date Modified Username Field Change
2019-02-05 09:44 rhertzog New Issue
2019-02-05 09:44 rhertzog Status new => assigned
2019-02-05 09:44 rhertzog Assigned To => rhertzog
2019-02-05 11:33 rhertzog Note Added: 0010258
2019-03-29 15:16 rhertzog Note Added: 0010459
2019-06-24 12:56 rhertzog Note Added: 0010729
2019-07-08 14:40 rhertzog Note Added: 0010770
2019-12-12 08:08 rhertzog Status assigned => resolved
2019-12-12 08:08 rhertzog Resolution open => fixed
2019-12-12 08:08 rhertzog Fixed in Version => 2019.4
2019-12-12 08:08 rhertzog Note Added: 0011659