View Issue Details

IDProjectCategoryView StatusLast Update
0005292Kali Linux[All Projects] Kali Package Bugpublic2019-03-08 13:52
ReportertheWhiteNightF00FAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005292: ca-certificates package is broken
DescriptionThe ca-certificates package's installation script fails, causing dpkg to report an error.
Steps To Reproducesudo apt-get update && sudo apt-get dist-upgrade
Additional Information100 joseph@kali ~ % sudo apt --fix-broken install :(
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
9 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up ca-certificates (20190110) ...
Updating certificates in /etc/ssl/certs...
dpkg: error processing package ca-certificates (--configure):
 installed ca-certificates package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of python3-requests:
 python3-requests depends on ca-certificates; however:
  Package ca-certificates is not configured yet.

dpkg: error processing package python3-requests (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of usbtop:
 usbtop depends on ca-certificates; however:
  Package ca-certificates is not configured yet.

dpkg: error processing package usbtop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-plotly:
 python3-plotly depends on python3-requests (>= 2.3.0); however:
  Package python3-requests is not configured yet.

dpkg: error processing package python3-plotly (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-requests:
 python-requests depends on ca-certificates; however:
  Package ca-certificates is not configured yet.

dpkg: error processing package python-requests (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ca-certificates-java:
 ca-certificates-java depends on ca-certificates (>= 20121114); however:
  Package ca-certificates is not configured yet.

dpkg: error processing package ca-certificates-java (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openshot-qt:
 openshot-qt depends on python3-requests; however:
  Package python3-requests is not configured yet.

dpkg: error processing package openshot-qt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of king-phisher:
 king-phisher depends on python3-requests (>= 2.11.1); however:
  Package python3-requests is not configured yet.

dpkg: error processing package king-phisher (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openshot:
 openshot depends on openshot-qt; however:
  Package openshot-qt is not configured yet.

dpkg: error processing package openshot (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ca-certificates
 python3-requests
 usbtop
 python3-plotly
 python-requests
 ca-certificates-java
 openshot-qt
 king-phisher
 openshot
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo apt --fix-broken install 5.16s user 1.01s system 37% cpu 16.639 total

Activities

sbrun

2019-03-08 13:52

manager   ~0010408

We don't reproduce this issue. Your issue may be the same as
the one mentioned in this bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922062

Issue History

Date Modified Username Field Change
2019-03-05 16:25 theWhiteNightF00F New Issue
2019-03-08 13:52 sbrun Assigned To => sbrun
2019-03-08 13:52 sbrun Status new => closed
2019-03-08 13:52 sbrun Resolution open => unable to reproduce
2019-03-08 13:52 sbrun Note Added: 0010408