View Issue Details

IDProjectCategoryView StatusLast Update
0005455Kali Linux[All Projects] General Bugpublic2019-05-21 07:14
Reporteraxel Assigned Tosbrun  
PriorityimmediateSeveritycrashReproducibilityrandom
Status closedResolutionduplicate 
Product Version2019.1 
Target VersionFixed in Version 
Summary0005455: wireless connection is suddenly interupted and wifi disconnected
Descriptionsince few days my wifi connection is suddenly interrupted (once a day on average) and this is accompanied by perturbations of sound and image as well as high use of cpu (by Kworker among others). the only way to restore the wifi connection is to reboot

lspci -k:
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Hewlett-Packard Company AR9285 Wireless Network Adapter (PCI-Express)
    Kernel driver in use: ath9k
    Kernel modules: ath9k

dmesg:
kernel: ath: phy0: Chip reset failed
kernel: ath: phy0: Unable to reset channel, reset status -22
kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff
ath: phy0: Failed to wakeup in 500us
phy0: RX failed to go idle in 10 ms RXSM=0xffffffff
[ 3380.433104] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffff

[ 2903.085111] irq 18: nobody cared (try booting with the "irqpoll" option)
[ 2903.085119] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 4.19.0-kali4-amd64 0000001 Debian 4.19.28-2kali1
[ 2903.085120] Hardware name: Hewlett-Packard HP 630 Notebook PC /3672, BIOS F.33 12/13/2011
[ 2903.085121] Call Trace:
[ 2903.085124] <IRQ>
[ 2903.085132] dump_stack+0x5c/0x80
[ 2903.085135] __report_bad_irq+0x3a/0xb4
[ 2903.085138] note_interrupt.cold.9+0xa/0x64
[ 2903.085140] handle_irq_event_percpu+0x6d/0x80
[ 2903.085141] handle_irq_event+0x3c/0x5c
[ 2903.085144] handle_fasteoi_irq+0x9c/0x160
[ 2903.085148] handle_irq+0x1f/0x30
[ 2903.085152] do_IRQ+0x49/0xd0
[ 2903.085154] common_interrupt+0xf/0xf
[ 2903.085155] </IRQ>
[ 2903.085159] RIP: 0010:cpuidle_enter_state+0xb6/0x320
[ 2903.085162] Code: 90 31 ff e8 ac 78 b1 ff 80 7c 24 0b 00 74 17 9c 58 66 66 90 66 90 f6 c4 02 0f 85 3b 02 00 00 31 ff e8 2e 52 b7 ff fb 66 66 90 <66> 66 90 48 b8 ff ff ff ff f3 01 00 00 48 2b 1c 24 ba ff ff ff 7f
[ 2903.085163] RSP: 0018:ffffbc66c06c3e90 EFLAGS: 00000246 ORIG_RAX: ffffffffffffffd8
[ 2903.085165] RAX: ffff96a34ba61c00 RBX: 000002a3ed5b30cf RCX: 000000000000001f
[ 2903.085166] RDX: 000002a3ed5b30cf RSI: 000000003a5062a9 RDI: 0000000000000000
[ 2903.085167] RBP: ffff96a34ba69f20 R08: 0000000000000002 R09: 00000000000214c0
[ 2903.085169] R10: 000005cf7e3bb27c R11: ffff96a34ba60be8 R12: 0000000000000001
[ 2903.085170] R13: ffffffffb1ab6df8 R14: 0000000000000001 R15: 0000000000000000
[ 2903.085173] do_idle+0x236/0x280
[ 2903.085175] cpu_startup_entry+0x6f/0x80
[ 2903.085180] start_secondary+0x1a4/0x1f0
[ 2903.085183] secondary_startup_64+0xa4/0xb0

rfkill list:
0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no


Relationships

duplicate of 0005454 closed wireless connection is suddenly interupted and wifi disconnected 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-05-20 19:39 axel New Issue
2019-05-20 19:39 axel Issue generated from: 0005454
2019-05-21 07:13 sbrun Relationship added duplicate of 0005454
2019-05-21 07:14 sbrun Assigned To => sbrun
2019-05-21 07:14 sbrun Status new => closed
2019-05-21 07:14 sbrun Resolution open => duplicate