View Issue Details

IDProjectCategoryView StatusLast Update
0005474Kali Linux[All Projects] Kali Package Bugpublic2019-09-19 09:08
Reporterg0tmi1k Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0005474: bdfproxy - can't run
Description```
g0tmi1k@kali-dev:~$ bdfproxy
Traceback (most recent call last):
  File "/usr/bin/bdfproxy", line 31, in <module>
    from bdfactory import pebin
ImportError: No module named bdfactory
g0tmi1k@kali-dev:~$
```


Fresh Kali 2019.2, using a normal (non root) user

Activities

sbrun

2019-06-04 09:49

manager   ~0010651

The missing module bdfactory is now available in Python 3 only.
bdfproxy is only Python 2 and it's not maintained anymore by upstream.

Update bdfproxy for Python 3 is not simple, because Python 2 and Python 3
 handle byte strings and Unicode differently.
Do we want to spend a lot of time fixing bdfproxy? This tool is broken
 since december 2018 (when backdoor-factory started using Python3) and we didn't get
any bug report as far as I know.

sbrun

2019-09-19 09:08

manager   ~0011129

bdfproxy has been removed

Issue History

Date Modified Username Field Change
2019-06-01 12:58 g0tmi1k New Issue
2019-06-04 09:49 sbrun Assigned To => sbrun
2019-06-04 09:49 sbrun Status new => feedback
2019-06-04 09:49 sbrun Note Added: 0010651
2019-09-19 09:08 sbrun Status feedback => closed
2019-09-19 09:08 sbrun Resolution open => won't fix
2019-09-19 09:08 sbrun Note Added: 0011129