View Issue Details

IDProjectCategoryView StatusLast Update
0005551Kali Linux[All Projects] Feature Requestspublic2019-06-18 10:40
Reporterg0tmi1k Assigned Tog0tmi1k  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2019.3Fixed in Version2019.3 
Summary0005551: Add kali-setup script
Description- Auto detect if in VM
- Based on detections, install packages for VMware/VirtualBox tools

Activities

g0tmi1k

2019-06-17 16:47

administrator   ~0010703

Pushed kali-defaults_2019.3.5

rhertzog

2019-06-18 08:54

administrator   ~0010704

Hey @g0tm1lk, can we discuss new features before they get implemented? I don't like how you go forward with things without any coordination.

I am wondering what's the purpose/use-case of this tool since debian-installer is already supposed to handle most of this (and I think it does for virtualbox)... and if it does not, we should fix it instead of adding a script of our own.

It's the hw-detect package which should handle this in d-i: https://tracker.debian.org/pkg/hw-detect

I see there's a bug for open-vm-tools auto-install:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782287

And a merge request ready as well:
https://salsa.debian.org/installer-team/hw-detect/merge_requests/2

Issue History

Date Modified Username Field Change
2019-06-17 16:33 g0tmi1k New Issue
2019-06-17 16:33 g0tmi1k Status new => assigned
2019-06-17 16:33 g0tmi1k Assigned To => g0tmi1k
2019-06-17 16:47 g0tmi1k Status assigned => resolved
2019-06-17 16:47 g0tmi1k Resolution open => fixed
2019-06-17 16:47 g0tmi1k Fixed in Version => 2019.3
2019-06-17 16:47 g0tmi1k Note Added: 0010703
2019-06-18 08:54 rhertzog Note Added: 0010704