View Issue Details

IDProjectCategoryView StatusLast Update
0005587Kali Linux[All Projects] General Bugpublic2019-07-16 12:35
Reporterradualexandrupopescu Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005587: Error encountered while upgrading: pdfbook unpack error, trying to overwrite '/usr/bin/pdfbook'
DescriptionI encountered this error while upgrading my Kali VM (last upgrade was 2 weeks ago if I recall correctly):

Errors were encountered while processing:
 /tmp/apt-dpkg-install-Uq85D4/245-pdfbook_0.1.0-1kali1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Upon further investigation it seems that the issue arrises from:

dpkg: error processing archive /var/cache/apt/archives/pdfbook_0.1.0-1kali1_all.deb (--unpack):
 trying to overwrite '/usr/bin/pdfbook', which is also in package texlive-extra-utils 2018.20190227-2
Additional InformationHere is the complete output: https://pastebin.com/p4bsUJj1

update.sh just runs 'apt update && apt dist-upgrade' and then runs git pull on all git repos in a directory.

Trying to 'fix' things:

root@kali:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  pdfbook
The following NEW packages will be installed:
  pdfbook
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
471 not fully installed or removed.
Need to get 0 B/6,982 B of archives.
After this operation, 26.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 659516 files and directories currently installed.)
Preparing to unpack .../pdfbook_0.1.0-1kali1_all.deb ...
Unpacking pdfbook (0.1.0-1kali1) ...
dpkg: error processing archive /var/cache/apt/archives/pdfbook_0.1.0-1kali1_all.deb (--unpack):
 trying to overwrite '/usr/bin/pdfbook', which is also in package texlive-extra-utils 2018.20190227-2
Errors were encountered while processing:
 /var/cache/apt/archives/pdfbook_0.1.0-1kali1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Activities

sbrun

2019-07-16 12:35

manager   ~0010781

fixed with kali-meta source package version 2019.3.9

the package pdfbook is removed from kali

Issue History

Date Modified Username Field Change
2019-07-13 00:54 radualexandrupopescu New Issue
2019-07-13 09:26 rhertzog Assigned To => sbrun
2019-07-13 09:26 rhertzog Status new => assigned
2019-07-16 12:35 sbrun Status assigned => resolved
2019-07-16 12:35 sbrun Resolution open => fixed
2019-07-16 12:35 sbrun Note Added: 0010781