View Issue Details

IDProjectCategoryView StatusLast Update
0005607Kali Linux[All Projects] Kali Package Bugpublic2019-08-16 05:40
ReporterRoseDeSableAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0005607: Cannot install packet python-libpcap - error code:1
DescriptionHello,
 I have a failure on my both systems while the installation of the packet "python-libpcap"

 python-libpcap
E: Sub-process /usr/bin/dpkg returned an error code (1)

Removing of the packet is possible without receiving further errors

Bye
Rose

Activities

crash

2019-08-08 12:50

reporter   ~0010828

Hi Rose,
Workaround:
Open the file /usr/lib/python2.7/dist-packages/pcap.py
Go to line 115 and add one space on the beginning of the line.

Basically from
   def __init__(self):
        import sys
        if int(sys.version[0])>=2:
        this = _pcap.new_pcapObject()

To:
   def __init__(self):
        import sys
        if int(sys.version[0])>=2:
         this = _pcap.new_pcapObject()

The t from "this" must be right under the f from "if"

Python stuff ...

Before adding the space:

root@Anubis:~# apt install python-libpcap
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-libpcap is already the newest version (0.6.4-1+b1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up python-libpcap (0.6.4-1+b1) ...
Sorry: IndentationError: expected an indented block (pcap.py, line 115)
dpkg: error processing package python-libpcap (--configure):
 installed python-libpcap package post-installation script subprocess returned error exit status 101
Errors were encountered while processing:
 python-libpcap
E: Sub-process /usr/bin/dpkg returned an error code (1)

After adding the space:

root@Anubis:~# apt install python-libpcap
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-libpcap is already the newest version (0.6.4-1+b1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up python-libpcap (0.6.4-1+b1) ...
root@Anubis:~#

RoseDeSable

2019-08-09 05:38

reporter   ~0010833

Good Morning Anubis,
 thank for the tip, but I wait for further regular packet updates of kali. In the case of products, which are installed by apt.., I don't want to intervene by my hands. I fear, that I could set the system in a state of outage, if I manipulate several of such programs.

Bye
Rise

crash

2019-08-09 07:10

reporter   ~0010835

Hi Rose,
Honestly, if you wanna use this pkg you need to change by your hands.
If you check here: https://tracker.debian.org/pkg/python-libpcap it is not maintained anymore.
The last update was in 2016. (:

rhertzog

2019-08-15 13:53

administrator   ~0010881

python-libpcap has been dropped from Debian and Kali. It looks like python-pypcap is a better alternative.

Issue History

Date Modified Username Field Change
2019-07-31 05:56 RoseDeSable New Issue
2019-08-08 12:50 crash Note Added: 0010828
2019-08-09 05:38 RoseDeSable Note Added: 0010833
2019-08-09 07:10 crash Note Added: 0010835
2019-08-15 13:53 rhertzog Assigned To => rhertzog
2019-08-15 13:53 rhertzog Status new => closed
2019-08-15 13:53 rhertzog Resolution open => won't fix
2019-08-15 13:53 rhertzog Note Added: 0010881