View Issue Details

IDProjectCategoryView StatusLast Update
0005690Kali Linux[All Projects] Kali Websites & Docspublic2019-09-16 08:36
ReporterFlipp3rrr Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005690: Kali.org status page shows "check_circle" text instead of an icon on Firefox
DescriptionWhen I go to https://status.kali.org/ with Firefox there's text like "check_circle" instead of icons, the browser log windows also gave 3 errors and multiple warnings.
Additional InformationOS: macOS Mojave

Browser version: Firefox 69.0

Browser log: https://pastebin.com/zc2ecbuf

Extensions that may intervene with the webpage:
- DuckDuckGo Privacy Essentials
- User-Agent Switcher
- Decentraleyes
- Cookie AutoDelete 3.0.2
- Privacy Badger
- uBlock Origin
- Dark Reader

I tried disabling all of the extensions mentioned above and the icons didn't show up. When using the Microsoft Edge Canary build the icons did show up.

Activities

Flipp3rrr

2019-09-12 19:02

reporter  

Flipp3rrr

2019-09-12 19:21

reporter   ~0011085

I'm sorry I forgot to add the following:
- My ISP is XS4ALL, located in the Netherlands
- I originally asked about this on Twitter, https://twitter.com/Flipp3rrr/status/1172214589146247174?s=20

rhertzog

2019-09-13 06:43

administrator   ~0011087

FWIW, it works fine with Firefox 69 on Linux. Somehow it just means that the CSS to replace in this code is not working:
<i class="material-icons" style="color: #00E673; cursor: pointer" title="Everything is OK!">check_circle

This code relies on the CSS coming from https://fonts.googleapis.com/icon?family=Material+Icons

It seems likely that one of your extension is forbidding the load of the above CSS or of the font referenced in the above CSS.

Can you disable all extensions, restart firefox and try again ?

Flipp3rrr

2019-09-15 13:09

reporter   ~0011089

Hello, I disabled all extensions but I still wasn't getting any icons. Then I noticed the little purple shield icon next to the green lock, it turns out the font was being blocked by the automated blocking built into Firefox.

Flipp3rrr

2019-09-15 13:10

reporter   ~0011090

Update: the exact URL being blocked by the built in tracking blocker is fonts.gstatic.com.

Flipp3rrr

2019-09-15 13:12

reporter   ~0011091

Update 2: I changed the built-in tracker blocklist from level 2 to level 1 which fixed the issue. I'm now closing this bug report.

Flipp3rrr

2019-09-15 13:14

reporter   ~0011092

Shit. I can't close the report. I guess I'll have to wait then.

rhertzog

2019-09-16 08:36

administrator   ~0011094

Thanks, closing.

Issue History

Date Modified Username Field Change
2019-09-12 19:02 Flipp3rrr New Issue
2019-09-12 19:02 Flipp3rrr File Added: Screenshot 2019-09-12 at 20.56.46.png
2019-09-12 19:21 Flipp3rrr Note Added: 0011085
2019-09-13 06:43 rhertzog Note Added: 0011087
2019-09-13 06:44 rhertzog Assigned To => rhertzog
2019-09-13 06:44 rhertzog Status new => feedback
2019-09-15 13:09 Flipp3rrr Note Added: 0011089
2019-09-15 13:09 Flipp3rrr Status feedback => assigned
2019-09-15 13:10 Flipp3rrr Note Added: 0011090
2019-09-15 13:12 Flipp3rrr Note Added: 0011091
2019-09-15 13:14 Flipp3rrr Note Added: 0011092
2019-09-16 08:36 rhertzog Status assigned => resolved
2019-09-16 08:36 rhertzog Resolution open => fixed
2019-09-16 08:36 rhertzog Note Added: 0011094